Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1237297
| From | Arnd Bergmann <arnd@arndb.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 11/13] Documentation: devicetree: ufs: Add DT bindings for exynos UFS host controller |
| Date | 2015-10-01 13:40 +0200 |
| Message-ID | <qeKnp-2Lo-37@gated-at.bofh.it> (permalink) |
| References | <qeHfQ-6EV-7@gated-at.bofh.it> <qeHpx-6S6-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thursday 01 October 2015 13:39:28 Alim Akhtar wrote: > From: Seungwon Jeon <essuuj@gmail.com> > > This adds Exynos Universal Flash Storage (UFS) Host Controller DT bindings. > > Signed-off-by: Seungwon Jeon <essuuj@gmail.com> > Signed-off-by: Alim Akhtar <alim.akhtar@samsung.com> > --- > .../devicetree/bindings/ufs/ufs-exynos.txt | 93 ++++++++++++++++++++ > 1 file changed, 93 insertions(+) > create mode 100644 Documentation/devicetree/bindings/ufs/ufs-exynos.txt > > diff --git a/Documentation/devicetree/bindings/ufs/ufs-exynos.txt b/Documentation/devicetree/bindings/ufs/ufs-exynos.txt > new file mode 100644 > index 0000000..00df72e > --- /dev/null > +++ b/Documentation/devicetree/bindings/ufs/ufs-exynos.txt > @@ -0,0 +1,93 @@ > +* Exynos Universal Flash Storage (UFS) Host Controller > + > +UFSHC nodes are defined to describe on-chip UFS host controllers. > +Each UFS controller instance should have its own node. > + > +Required properties: > +- compatible : compatible name, contains "samsung,exynos7-ufs" > +- interrupts : <interrupt mapping for UFS host controller IRQ> > +- reg : <registers mapping> This needs a list of all the register ranges, which order they are in and what the respective strings must be. > +- clocks : List of phandle and clock specifier pairs > +- clock-names : List of clock input name strings sorted in the same > + order as the clocks property. You need to list the names you require here. Also the 'clock specifier' includes the phandle, it's not a pair but just a list of specifiers. > +- ufs,pwr-attr-mode : specifies mode value for power mode change > +- ufs,pwr-attr-lane : specifies lane count value for power mode change > +- ufs,pwr-attr-gear : specifies gear count value for power mode change > +- ufs,pwr-attr-hs-series : specifies HS rate series for power mode change > +- ufs,pwr-local-l2-timer : specifies array of local UNIPRO L2 timer values > + <FC0ProtectionTimeOutVal,TC0ReplayTimeOutVal, AFC0ReqTimeOutVal> > +- ufs,pwr-remote-l2-timer : specifies array of remote UNIPRO L2 timer values > + <FC0ProtectionTimeOutVal,TC0ReplayTimeOutVal, AFC0ReqTimeOutVal> > +- ufs-rx-adv-fine-gran-sup_en : specifies support of fine granularity of MPHY, > + this is a boolean property. > +- ufs-rx-adv-fine-gran-step : specifies granularity steps of MPHY > +- ufs-rx-adv-min-activate-time-cap : specifies rx advanced minimum activate time of MPHY > +- ufs-pa-granularity : specifies Granularity for PA_TActivate and PA_Hibern8Time > +- ufs-pa-tacctivate : specifies time wake-up remote M-RX > +- ufs-pa-hibern8time : specifies minimum time to wait in HIBERN8 state These all require a specification of what the allowed values are and/or the units for the numbers. > + > + clocks = <&core 0>, <&ref 0>, <&iface 0>; > + clock-names = "core_clk", "ref_clk", "iface_clk"; Better rename them to "core", "ref" and "iface", no point requiring to spell out "clk" here. > + ufs,pwr-attr-mode = "FAST"; A string is rather unusual here, what are the allowed values? Could you use a boolean property instead? > + ufs,pwr-attr-lane = /bits/ 8 <2>; > + ufs,pwr-attr-gear = /bits/ 8 <2>; Why the "/bits/ 8" ? Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v3 00/13] exynos-ufs: add support for Exynos Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:20 +0200
[PATCH v3 01/13] Documentation: samsung-phy: Add dt bindings for UFS Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:20 +0200
[PATCH v3 02/13] phy: exynos-ufs: add UFS PHY driver for EXYNOS SoC Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
Re: [PATCH v3 02/13] phy: exynos-ufs: add UFS PHY driver for EXYNOS SoC kbuild test robot <lkp@intel.com> - 2015-10-01 10:50 +0200
[PATCH] phy: exynos-ufs: fix platform_no_drv_owner.cocci warnings kbuild test robot <lkp@intel.com> - 2015-10-01 10:50 +0200
[RFC PATCH] phy: exynos-ufs: exynos_ufs_phy_calibrate() can be static kbuild test robot <lkp@intel.com> - 2015-10-01 13:10 +0200
Re: [PATCH v3 02/13] phy: exynos-ufs: add UFS PHY driver for EXYNOS SoC kbuild test robot <lkp@intel.com> - 2015-10-01 13:10 +0200
[PATCH v3 06/13] scsi: ufs: add quirk to enable host controller without hce Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
[PATCH v3 04/13] scsi: ufs: add quirk to fix mishandling utrlclr/utmrlclr Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
[PATCH v3 03/13] scsi: ufs: add quirk to contain unconformable utrd field Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
[PATCH v3 08/13] scsi: ufs: add add specific callback for hibern8 Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
[PATCH v3 07/13] scsi: ufs: add specific callback for nexus type Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
[PATCH v3 13/13] scsi: ufs: Add exynos ufs platform data Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
Re: [PATCH v3 13/13] scsi: ufs: Add exynos ufs platform data kbuild test robot <lkp@intel.com> - 2015-10-01 12:10 +0200
[PATCH v3 11/13] Documentation: devicetree: ufs: Add DT bindings for exynos UFS host controller Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
Re: [PATCH v3 11/13] Documentation: devicetree: ufs: Add DT bindings for exynos UFS host controller Arnd Bergmann <arnd@arndb.de> - 2015-10-01 13:40 +0200
[PATCH v3 05/13] scsi: ufs: add quirk not to allow reset of interrupt aggregation Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
[PATCH v3 10/13] scsi: ufs: return value of pwr_change_notify Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
[PATCH v3 09/13] scsi: ufs: make ufshcd_config_pwr_mode of non-static func Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-01 10:30 +0200
Re: [PATCH v3 12/13] scsi: ufs-exynos: add UFS host support for Exynos SoCs Arnd Bergmann <arnd@arndb.de> - 2015-10-01 14:20 +0200
csiph-web