Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1324918

[PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c

From Byeoungwook Kim <quddnr145@gmail.com>
Newsgroups linux.kernel
Subject [PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c
Date 2016-02-03 06:30 +0100
Message-ID <qXYaR-63Z-1@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


Conditional codes in rtl_addr_delay() were improved in readability and
performance by using switch codes.

Reviewed-by: Julian Calaby <julian.calaby@gmail.com>
Signed-off-by: Byeoungwook Kim <quddnr145@gmail.com>
Signed-off-by: Fengguang Wu <fengguang.wu@intel.com>
---
V3 remove unneeded semicolon.
V2 split in separate patchs.
 drivers/net/wireless/realtek/rtlwifi/core.c | 20 ++++++++++++++------
 1 file changed, 14 insertions(+), 6 deletions(-)

diff --git a/drivers/net/wireless/realtek/rtlwifi/core.c b/drivers/net/wireless/realtek/rtlwifi/core.c
index 4ae421e..63cda78 100644
--- a/drivers/net/wireless/realtek/rtlwifi/core.c
+++ b/drivers/net/wireless/realtek/rtlwifi/core.c
@@ -37,18 +37,26 @@
 
 void rtl_addr_delay(u32 addr)
 {
-	if (addr == 0xfe)
+	switch (addr) {
+	case 0xfe:
 		mdelay(50);
-	else if (addr == 0xfd)
+		break;
+	case 0xfd:
 		mdelay(5);
-	else if (addr == 0xfc)
+		break;
+	case 0xfc:
 		mdelay(1);
-	else if (addr == 0xfb)
+		break;
+	case 0xfb:
 		udelay(50);
-	else if (addr == 0xfa)
+		break;
+	case 0xfa:
 		udelay(5);
-	else if (addr == 0xf9)
+		break;
+	case 0xf9:
 		udelay(1);
+		break;
+	}
 }
 EXPORT_SYMBOL(rtl_addr_delay);
 
-- 
2.5.0

Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

[PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c Byeoungwook Kim <quddnr145@gmail.com> - 2016-02-03 06:30 +0100
  Re: [PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in  core.c Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2016-02-03 10:00 +0100
    Re: [PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c ByeoungWook Kim <quddnr145@gmail.com> - 2016-02-03 10:20 +0100

csiph-web