Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1324918
| Path | csiph.com!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Byeoungwook Kim <quddnr145@gmail.com> |
| Newsgroups | linux.kernel |
| Subject | [PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c |
| Date | Wed, 03 Feb 2016 06:30:01 +0100 |
| Message-ID | <qXYaR-63Z-1@gated-at.bofh.it> (permalink) |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=date:from:to:cc:subject:message-id:mime-version:content-type :content-disposition:user-agent; bh=Ng49/is5Z6HpI9T7EVqEpITwVnNZClP2KZKZyUTniJo=; b=SPN2owjMkKDY4uxrpt3UEK2eG1s1XYi5985GPtneYo+iLzOuU5eNRler2S9clte2lg bp0cQEGAcNmb7nM3J00RBNxBVX41MJUKUpny3ckB+KKqV+4Glh86050C9iD9S+R6R9Hy 1Ne4teDrOyR8sf/vvQt2v183grtYbH1H4EkPU5X2JGrTdWY3UA+dRDVJZjhNOIiKxLBh e8/e4sExLbym8sMwHw2gJtEnzbX4Fh3HbHTFIWsej19DKJ9sWkWDx4ICB3PjB/ZT0+0s SC3rcVorHXBTEbIXXyftc19AKNh4J7sjFLJoghN1vLek3SBu2weQ/B+sQ6SGvtXkNQZa 6XQw== |
| X-Google-Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:date:from:to:cc:subject:message-id:mime-version :content-type:content-disposition:user-agent; bh=Ng49/is5Z6HpI9T7EVqEpITwVnNZClP2KZKZyUTniJo=; b=MOcXmuq6h0LgQroVmXWDyQvCvFpD5CdaIoBlp5hFtW9yhwuZZVCQ6golQIVdEsxalO e8dqfMnpyYPeaAEZddfWy38XqwDWtl+U2NokmgkW6hyrIs8sZDnpTavxwkPEyIF4nGq3 pylt7VFpG51C+5Z46j8KsIzRJJDpcdavvenNmYZp9b9NsVSllnL+WLcxButf5L1iJqMt JICfizOPLCzRdkT8nFhG2hTvT7wkEdOi/ATDyRGksKYaJhc+PwIWExuCPbkb9EiagP6L rY9kUiCLJNU6HN8xX8Ai4cpzZbJN3Hc5b6q5skwcMCHS+bkIn/uJVhbR3cDIRqLPMWtM 3WCA== |
| X-Gm-Message-State | AG10YOS+RhwHpB4fqmoIrqmC9hmGawLrOUrgqqc7O1eAbHraiHEJjz8vQvoAtF8U8NLaAw== |
| X-Received | by 10.98.14.68 with SMTP id w65mr54110717pfi.146.1454476913435; Tue, 02 Feb 2016 21:21:53 -0800 (PST) |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset=us-ascii |
| Content-Disposition | inline |
| User-Agent | Mutt/1.5.23 (2014-03-12) |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 51 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | kvalo@codeaurora.org, chaoming_li@realsil.com.cn, linux-wireless@vger.kernel.org, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, lkp@intel.com, julian.calaby@gmail.com |
| X-Original-Date | Wed, 3 Feb 2016 14:21:46 +0900 |
| X-Original-Message-ID | <20160203052146.GA15711@gmail.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1324918 |
Show key headers only | View raw
Conditional codes in rtl_addr_delay() were improved in readability and
performance by using switch codes.
Reviewed-by: Julian Calaby <julian.calaby@gmail.com>
Signed-off-by: Byeoungwook Kim <quddnr145@gmail.com>
Signed-off-by: Fengguang Wu <fengguang.wu@intel.com>
---
V3 remove unneeded semicolon.
V2 split in separate patchs.
drivers/net/wireless/realtek/rtlwifi/core.c | 20 ++++++++++++++------
1 file changed, 14 insertions(+), 6 deletions(-)
diff --git a/drivers/net/wireless/realtek/rtlwifi/core.c b/drivers/net/wireless/realtek/rtlwifi/core.c
index 4ae421e..63cda78 100644
--- a/drivers/net/wireless/realtek/rtlwifi/core.c
+++ b/drivers/net/wireless/realtek/rtlwifi/core.c
@@ -37,18 +37,26 @@
void rtl_addr_delay(u32 addr)
{
- if (addr == 0xfe)
+ switch (addr) {
+ case 0xfe:
mdelay(50);
- else if (addr == 0xfd)
+ break;
+ case 0xfd:
mdelay(5);
- else if (addr == 0xfc)
+ break;
+ case 0xfc:
mdelay(1);
- else if (addr == 0xfb)
+ break;
+ case 0xfb:
udelay(50);
- else if (addr == 0xfa)
+ break;
+ case 0xfa:
udelay(5);
- else if (addr == 0xf9)
+ break;
+ case 0xf9:
udelay(1);
+ break;
+ }
}
EXPORT_SYMBOL(rtl_addr_delay);
--
2.5.0
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c Byeoungwook Kim <quddnr145@gmail.com> - 2016-02-03 06:30 +0100
Re: [PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2016-02-03 10:00 +0100
Re: [PATCH v3] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c ByeoungWook Kim <quddnr145@gmail.com> - 2016-02-03 10:20 +0100
csiph-web