Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1197981
| From | Pali Rohár <pali.rohar@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 05/15] drivers: input: Drop unlikely before IS_ERR(_OR_NULL) |
| Date | 2015-08-01 13:50 +0200 |
| Message-ID | <pSDsB-3CW-3@gated-at.bofh.it> (permalink) |
| References | <pSe1b-aE-3@gated-at.bofh.it> <pSlP4-3eU-1@gated-at.bofh.it> <pSD9f-3gj-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
On Saturday 01 August 2015 13:22:51 Viresh Kumar wrote: > On 31-07-15, 09:58, Dmitry Torokhov wrote: > > On Fri, Jul 31, 2015 at 02:08:25PM +0530, Viresh Kumar wrote: > > > IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and > > > there is no need to do that again from its callers. Drop it. > > > > I'd rather keep it as it documents the expected behavior and double > > unlikely should work just fine. > > TBH, I don't really agree that it is there for documentation. The > only purpose of such compiler flags is to try make code more > efficient. > > Anyway, I got to this series as someone asked me to fix this for one > of my patches which used unlikely(IS_ERR_OR_NULL()). And so I > thought about fixing all sites that are doing double unlikely (that > shouldn't hurt for sure). > > I will leave it to you. I think that unlikely() macro here make code more readable. Yes, it is also for compiler optimization, but also for me it looks like Clean Code pattern <https://de.wikipedia.org/wiki/Clean_Code> -- is not it? -- Pali Rohár pali.rohar@gmail.com
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH 05/15] drivers: input: Drop unlikely before IS_ERR(_OR_NULL) Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-07-31 19:00 +0200
Re: [PATCH 05/15] drivers: input: Drop unlikely before IS_ERR(_OR_NULL) Viresh Kumar <viresh.kumar@linaro.org> - 2015-08-01 13:30 +0200
Re: [PATCH 05/15] drivers: input: Drop unlikely before IS_ERR(_OR_NULL) Pali Rohár <pali.rohar@gmail.com> - 2015-08-01 13:50 +0200
Re: [PATCH 05/15] drivers: input: Drop unlikely before IS_ERR(_OR_NULL) Pali Rohár <pali.rohar@gmail.com> - 2015-08-02 18:00 +0200
Re: [PATCH 05/15] drivers: input: Drop unlikely before IS_ERR(_OR_NULL) Pavel Machek <pavel@ucw.cz> - 2015-08-02 17:50 +0200
csiph-web