Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1591072 > unrolled thread
| Started by | Aleksey Makarov <aleksey.makarov@linaro.org> |
|---|---|
| First post | 2017-03-02 14:20 +0100 |
| Last post | 2017-03-02 17:50 +0100 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH v2 2/3] printk: rename selected_console -> preferred_console Aleksey Makarov <aleksey.makarov@linaro.org> - 2017-03-02 14:20 +0100
Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console Steven Rostedt <rostedt@goodmis.org> - 2017-03-02 16:10 +0100
Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console Sergey Senozhatsky <sergey.senozhatsky@gmail.com> - 2017-03-02 17:50 +0100
| From | Aleksey Makarov <aleksey.makarov@linaro.org> |
|---|---|
| Date | 2017-03-02 14:20 +0100 |
| Subject | [PATCH v2 2/3] printk: rename selected_console -> preferred_console |
| Message-ID | <tgyOd-2Mh-17@gated-at.bofh.it> |
The variable selected_console is set in __add_preferred_console()
to point to the last console parameter that was added to the
console_cmdline array.
Rename it to preferred_console so that the name reflects the usage.
Suggested-by: Peter Hurley <peter@hurleysoftware.com>
Signed-off-by: Aleksey Makarov <aleksey.makarov@linaro.org>
---
kernel/printk/printk.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/kernel/printk/printk.c b/kernel/printk/printk.c
index 3c2234f21291..ed2a9b31f214 100644
--- a/kernel/printk/printk.c
+++ b/kernel/printk/printk.c
@@ -267,7 +267,7 @@ static struct console *exclusive_console;
static struct console_cmdline console_cmdline[MAX_CMDLINECONSOLES];
-static int selected_console = -1;
+static int preferred_console = -1;
int console_set_on_cmdline;
EXPORT_SYMBOL(console_set_on_cmdline);
@@ -1907,14 +1907,14 @@ static int __add_preferred_console(char *name, int idx, char *options,
i++, c++) {
if (strcmp(c->name, name) == 0 && c->index == idx) {
if (!brl_options)
- selected_console = i;
+ preferred_console = i;
return 0;
}
}
if (i == MAX_CMDLINECONSOLES)
return -E2BIG;
if (!brl_options)
- selected_console = i;
+ preferred_console = i;
strlcpy(c->name, name, sizeof(c->name));
c->options = options;
braille_set_options(c, brl_options);
@@ -2433,7 +2433,7 @@ void register_console(struct console *newcon)
bcon = console_drivers;
if (!has_preferred || bcon || !console_drivers)
- has_preferred = selected_console >= 0;
+ has_preferred = preferred_console >= 0;
/*
* See if we want to use this console driver. If we
@@ -2481,7 +2481,7 @@ void register_console(struct console *newcon)
}
newcon->flags |= CON_ENABLED;
- if (i == selected_console) {
+ if (i == preferred_console) {
newcon->flags |= CON_CONSDEV;
has_preferred = true;
}
--
2.11.1
[toc] | [next] | [standalone]
| From | Steven Rostedt <rostedt@goodmis.org> |
|---|---|
| Date | 2017-03-02 16:10 +0100 |
| Subject | Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console |
| Message-ID | <tgAwG-3Yt-27@gated-at.bofh.it> |
| In reply to | #1591072 |
On Thu, 2 Mar 2017 16:11:33 +0300 Aleksey Makarov <aleksey.makarov@linaro.org> wrote: > The variable selected_console is set in __add_preferred_console() > to point to the last console parameter that was added to the > console_cmdline array. > > Rename it to preferred_console so that the name reflects the usage. As I said previously, I prefer "selected_console" but since "__add_preferred_console()" sets it, I'm fine with this change. Although, I would probably have changed that function to "__add_selected_console()" :) Acked-by: Steven Rostedt (VMware) <rostedt@goodmis.org> -- Steve > > Suggested-by: Peter Hurley <peter@hurleysoftware.com> > Signed-off-by: Aleksey Makarov <aleksey.makarov@linaro.org>
[toc] | [prev] | [next] | [standalone]
| From | Sergey Senozhatsky <sergey.senozhatsky@gmail.com> |
|---|---|
| Date | 2017-03-02 17:50 +0100 |
| Subject | Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console |
| Message-ID | <tgC5s-53e-11@gated-at.bofh.it> |
| In reply to | #1591176 |
On (03/02/17 10:01), Steven Rostedt wrote: > > The variable selected_console is set in __add_preferred_console() > > to point to the last console parameter that was added to the > > console_cmdline array. > > > > Rename it to preferred_console so that the name reflects the usage. > > As I said previously, I prefer "selected_console" but since > "__add_preferred_console()" sets it, I'm fine with this change. > Although, I would probably have changed that function to > "__add_selected_console()" :) > > Acked-by: Steven Rostedt (VMware) <rostedt@goodmis.org> agree, I'd *probably* do a function rename. just 3 lines of code to touch (afaics). Reviewed-by: Sergey Senozhatsky <sergey.senozhatsky@gmail.com> -ss
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web