Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1591176

Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console

From Steven Rostedt <rostedt@goodmis.org>
Newsgroups linux.kernel
Subject Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console
Date 2017-03-02 16:10 +0100
Message-ID <tgAwG-3Yt-27@gated-at.bofh.it> (permalink)
References <tgyOd-2Mh-19@gated-at.bofh.it> <tgyOd-2Mh-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu,  2 Mar 2017 16:11:33 +0300
Aleksey Makarov <aleksey.makarov@linaro.org> wrote:

> The variable selected_console is set in __add_preferred_console()
> to point to the last console parameter that was added to the
> console_cmdline array.
> 
> Rename it to preferred_console so that the name reflects the usage.

As I said previously, I prefer "selected_console" but since
"__add_preferred_console()" sets it, I'm fine with this change.
Although, I would probably have changed that function to
"__add_selected_console()" :)

Acked-by: Steven Rostedt (VMware) <rostedt@goodmis.org>

-- Steve

> 
> Suggested-by: Peter Hurley <peter@hurleysoftware.com>
> Signed-off-by: Aleksey Makarov <aleksey.makarov@linaro.org>

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 2/3] printk: rename selected_console -> preferred_console Aleksey Makarov <aleksey.makarov@linaro.org> - 2017-03-02 14:20 +0100
  Re: [PATCH v2 2/3] printk: rename selected_console ->  preferred_console Steven Rostedt <rostedt@goodmis.org> - 2017-03-02 16:10 +0100
    Re: [PATCH v2 2/3] printk: rename selected_console ->  preferred_console Sergey Senozhatsky <sergey.senozhatsky@gmail.com> - 2017-03-02 17:50 +0100

csiph-web