Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1587975 > unrolled thread
| Started by | Tahia Khan <tahia.khan@gmail.com> |
|---|---|
| First post | 2017-02-24 23:10 +0100 |
| Last post | 2017-02-24 23:10 +0100 |
| Articles | 4 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH v4 0/3] staging: wilc1000: multiple coding style changes to struct tstrRSSI Tahia Khan <tahia.khan@gmail.com> - 2017-02-24 23:10 +0100
[PATCH v4 1/3] staging: wilc1000: Rename struct tstrRSSI to rssi_history_buffer Tahia Khan <tahia.khan@gmail.com> - 2017-02-24 23:10 +0100
Re: [Outreachy kernel] [PATCH v4 1/3] staging: wilc1000: Rename struct tstrRSSI to rssi_history_buffer Julia Lawall <julia.lawall@lip6.fr> - 2017-02-25 07:50 +0100
[PATCH v4 3/3] staging: wilc1000: Rename network_info member str_rssi to rssi_history Tahia Khan <tahia.khan@gmail.com> - 2017-02-24 23:10 +0100
| From | Tahia Khan <tahia.khan@gmail.com> |
|---|---|
| Date | 2017-02-24 23:10 +0100 |
| Subject | [PATCH v4 0/3] staging: wilc1000: multiple coding style changes to struct tstrRSSI |
| Message-ID | <tewdP-6CD-9@gated-at.bofh.it> |
Multiple coding style changes to struct tstrRSSI. Initially reported by checkpath.pl:
Avoid CamelCase: <tstrRSSI>
Avoid CamelCase: <u8Full>
Avoid CamelCase: <u8Index>
Changes since v3: Reformatting commit messages, as requested by
Julia Lawall <julia.lawall@lip6.fr>
Tahia Khan (3):
staging: wilc1000: Rename struct tstrRSSI to rssi_history_buffer for
clarity and to remove camel casing.
staging: wilc1000: Remove Hungarian notation and camel casing from all
tstrRSSI members’ names. Additionally, change type of u8Full to bool
since it only takes values 1 or 0.
staging: wilc1000: Change name of str_rssi to rssi_history within the
network_info struct for clarity.
drivers/staging/wilc1000/coreconfigurator.h | 10 +++++-----
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14 +++++++-------
2 files changed, 12 insertions(+), 12 deletions(-)
--
2.7.4
[toc] | [next] | [standalone]
| From | Tahia Khan <tahia.khan@gmail.com> |
|---|---|
| Date | 2017-02-24 23:10 +0100 |
| Subject | [PATCH v4 1/3] staging: wilc1000: Rename struct tstrRSSI to rssi_history_buffer |
| Message-ID | <tewdQ-6CD-25@gated-at.bofh.it> |
| In reply to | #1587975 |
Rename struct tstrRSSI to rssi_history_buffer for clarity
and to remove camel casing.
Signed-off-by: Tahia Khan <tahia.khan@gmail.com>
---
drivers/staging/wilc1000/coreconfigurator.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.h b/drivers/staging/wilc1000/coreconfigurator.h
index cff1698..1c77529 100644
--- a/drivers/staging/wilc1000/coreconfigurator.h
+++ b/drivers/staging/wilc1000/coreconfigurator.h
@@ -70,7 +70,7 @@ enum connect_status {
CONNECT_STS_FORCE_16_BIT = 0xFFFF
};
-struct tstrRSSI {
+struct rssi_history_buffer {
u8 u8Full;
u8 u8Index;
s8 as8RSSI[NUM_RSSI];
@@ -93,7 +93,7 @@ struct network_info {
u8 *ies;
u16 ies_len;
void *join_params;
- struct tstrRSSI str_rssi;
+ struct rssi_history_buffer str_rssi;
u64 tsf_hi;
};
--
2.7.4
[toc] | [prev] | [next] | [standalone]
| From | Julia Lawall <julia.lawall@lip6.fr> |
|---|---|
| Date | 2017-02-25 07:50 +0100 |
| Subject | Re: [Outreachy kernel] [PATCH v4 1/3] staging: wilc1000: Rename struct tstrRSSI to rssi_history_buffer |
| Message-ID | <teEl3-3Sv-3@gated-at.bofh.it> |
| In reply to | #1587977 |
On Fri, 24 Feb 2017, Tahia Khan wrote:
> Rename struct tstrRSSI to rssi_history_buffer for clarity
> and to remove camel casing.
>
> Signed-off-by: Tahia Khan <tahia.khan@gmail.com>
Acked-by: Julia Lawall <julia.lawall@lip6.fr>
> ---
> drivers/staging/wilc1000/coreconfigurator.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/wilc1000/coreconfigurator.h b/drivers/staging/wilc1000/coreconfigurator.h
> index cff1698..1c77529 100644
> --- a/drivers/staging/wilc1000/coreconfigurator.h
> +++ b/drivers/staging/wilc1000/coreconfigurator.h
> @@ -70,7 +70,7 @@ enum connect_status {
> CONNECT_STS_FORCE_16_BIT = 0xFFFF
> };
>
> -struct tstrRSSI {
> +struct rssi_history_buffer {
> u8 u8Full;
> u8 u8Index;
> s8 as8RSSI[NUM_RSSI];
> @@ -93,7 +93,7 @@ struct network_info {
> u8 *ies;
> u16 ies_len;
> void *join_params;
> - struct tstrRSSI str_rssi;
> + struct rssi_history_buffer str_rssi;
> u64 tsf_hi;
> };
>
> --
> 2.7.4
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/da73d1aef379243ba94a5c1a4e1d6663160451fd.1487947616.git.tahia.khan%40gmail.com.
> For more options, visit https://groups.google.com/d/optout.
>
[toc] | [prev] | [next] | [standalone]
| From | Tahia Khan <tahia.khan@gmail.com> |
|---|---|
| Date | 2017-02-24 23:10 +0100 |
| Subject | [PATCH v4 3/3] staging: wilc1000: Rename network_info member str_rssi to rssi_history |
| Message-ID | <tewdQ-6CD-29@gated-at.bofh.it> |
| In reply to | #1587975 |
Change name of str_rssi to rssi_history within the network_info
struct for clarity.
Signed-off-by: Tahia Khan <tahia.khan@gmail.com>
Acked-by: Julia Lawall <julia.lawall@lip6.fr>
---
drivers/staging/wilc1000/coreconfigurator.h | 2 +-
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14 +++++++-------
2 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.h b/drivers/staging/wilc1000/coreconfigurator.h
index 9712d89..10101f8 100644
--- a/drivers/staging/wilc1000/coreconfigurator.h
+++ b/drivers/staging/wilc1000/coreconfigurator.h
@@ -93,7 +93,7 @@ struct network_info {
u8 *ies;
u16 ies_len;
void *join_params;
- struct rssi_history_buffer str_rssi;
+ struct rssi_history_buffer rssi_history;
u64 tsf_hi;
};
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
index 9601ab8..4a6fe90 100644
--- a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
+++ b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
@@ -205,11 +205,11 @@ static u32 get_rssi_avg(struct network_info *network_info)
{
u8 i;
int rssi_v = 0;
- u8 num_rssi = (network_info->str_rssi.full) ?
- NUM_RSSI : (network_info->str_rssi.index);
+ u8 num_rssi = (network_info->rssi_history.full) ?
+ NUM_RSSI : (network_info->rssi_history.index);
for (i = 0; i < num_rssi; i++)
- rssi_v += network_info->str_rssi.samples[i];
+ rssi_v += network_info->rssi_history.samples[i];
rssi_v /= num_rssi;
return rssi_v;
@@ -346,13 +346,13 @@ static void add_network_to_shadow(struct network_info *pstrNetworkInfo,
} else {
ap_index = ap_found;
}
- rssi_index = last_scanned_shadow[ap_index].str_rssi.index;
- last_scanned_shadow[ap_index].str_rssi.samples[rssi_index++] = pstrNetworkInfo->rssi;
+ rssi_index = last_scanned_shadow[ap_index].rssi_history.index;
+ last_scanned_shadow[ap_index].rssi_history.samples[rssi_index++] = pstrNetworkInfo->rssi;
if (rssi_index == NUM_RSSI) {
rssi_index = 0;
- last_scanned_shadow[ap_index].str_rssi.full = true;
+ last_scanned_shadow[ap_index].rssi_history.full = true;
}
- last_scanned_shadow[ap_index].str_rssi.index = rssi_index;
+ last_scanned_shadow[ap_index].rssi_history.index = rssi_index;
last_scanned_shadow[ap_index].rssi = pstrNetworkInfo->rssi;
last_scanned_shadow[ap_index].cap_info = pstrNetworkInfo->cap_info;
last_scanned_shadow[ap_index].ssid_len = pstrNetworkInfo->ssid_len;
--
2.7.4
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web