Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1672380 > unrolled thread

Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code

Started byMika Westerberg <mika.westerberg@linux.intel.com>
First post2017-06-22 09:40 +0200
Last post2017-06-26 15:40 +0200
Articles 4 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code Mika Westerberg <mika.westerberg@linux.intel.com> - 2017-06-22 09:40 +0200
    Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-06-22 16:50 +0200
      Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-06-23 03:20 +0200
        Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code Mika Westerberg <mika.westerberg@linux.intel.com> - 2017-06-26 15:40 +0200

#1672380 — Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code

FromMika Westerberg <mika.westerberg@linux.intel.com>
Date2017-06-22 09:40 +0200
SubjectRe: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code
Message-ID<tV4SC-1wt-27@gated-at.bofh.it>
On Mon, Jun 19, 2017 at 11:33:52PM +0200, Rafael J. Wysocki wrote:
> -#ifdef CONFIG_PM_SLEEP
> -/**
> - * acpi_pm_device_sleep_wake - Enable or disable device to wake up the system.
> - * @dev: Device to enable/desible to wake up the system from sleep states.
> - * @enable: Whether to enable or disable @dev to wake up the system.
> - */
> -int acpi_pm_device_sleep_wake(struct device *dev, bool enable)
> +int acpi_pm_device_wakeup(struct device *dev, bool enable)

Can we call it acpi_pm_device_enable_wakeup() and then provide
corresponding acpi_pm_device_disable_wakeup()? I find those easier to
understand than acpi_pm_device_wakeup() that sounds like the device
should be woken up now.

[toc] | [next] | [standalone]


#1672704

From"Rafael J. Wysocki" <rjw@rjwysocki.net>
Date2017-06-22 16:50 +0200
Message-ID<tVbAL-62K-27@gated-at.bofh.it>
In reply to#1672380
On Thursday, June 22, 2017 10:39:37 AM Mika Westerberg wrote:
> On Mon, Jun 19, 2017 at 11:33:52PM +0200, Rafael J. Wysocki wrote:
> > -#ifdef CONFIG_PM_SLEEP
> > -/**
> > - * acpi_pm_device_sleep_wake - Enable or disable device to wake up the system.
> > - * @dev: Device to enable/desible to wake up the system from sleep states.
> > - * @enable: Whether to enable or disable @dev to wake up the system.
> > - */
> > -int acpi_pm_device_sleep_wake(struct device *dev, bool enable)
> > +int acpi_pm_device_wakeup(struct device *dev, bool enable)
> 
> Can we call it acpi_pm_device_enable_wakeup() and then provide
> corresponding acpi_pm_device_disable_wakeup()? I find those easier to
> understand than acpi_pm_device_wakeup() that sounds like the device
> should be woken up now.

OK, fair enough.  I'll change it this way.

[toc] | [prev] | [next] | [standalone]


#1673165

From"Rafael J. Wysocki" <rjw@rjwysocki.net>
Date2017-06-23 03:20 +0200
Message-ID<tVlqq-3Vc-9@gated-at.bofh.it>
In reply to#1672704
On Thursday, June 22, 2017 04:38:49 PM Rafael J. Wysocki wrote:
> On Thursday, June 22, 2017 10:39:37 AM Mika Westerberg wrote:
> > On Mon, Jun 19, 2017 at 11:33:52PM +0200, Rafael J. Wysocki wrote:
> > > -#ifdef CONFIG_PM_SLEEP
> > > -/**
> > > - * acpi_pm_device_sleep_wake - Enable or disable device to wake up the system.
> > > - * @dev: Device to enable/desible to wake up the system from sleep states.
> > > - * @enable: Whether to enable or disable @dev to wake up the system.
> > > - */
> > > -int acpi_pm_device_sleep_wake(struct device *dev, bool enable)
> > > +int acpi_pm_device_wakeup(struct device *dev, bool enable)
> > 
> > Can we call it acpi_pm_device_enable_wakeup() and then provide
> > corresponding acpi_pm_device_disable_wakeup()? I find those easier to
> > understand than acpi_pm_device_wakeup() that sounds like the device
> > should be woken up now.
> 
> OK, fair enough.  I'll change it this way.

Well, sorry, I'd rather not to, or we'll have to add a wrapper around them in
pci-acpi.c. :-)

I can rename it to acpi_pm_device_set_wakeup(), though.

Thanks,
Rafael

[toc] | [prev] | [next] | [standalone]


#1674790

FromMika Westerberg <mika.westerberg@linux.intel.com>
Date2017-06-26 15:40 +0200
Message-ID<tWCpd-2Xw-41@gated-at.bofh.it>
In reply to#1673165
On Fri, Jun 23, 2017 at 03:05:57AM +0200, Rafael J. Wysocki wrote:
> On Thursday, June 22, 2017 04:38:49 PM Rafael J. Wysocki wrote:
> > On Thursday, June 22, 2017 10:39:37 AM Mika Westerberg wrote:
> > > On Mon, Jun 19, 2017 at 11:33:52PM +0200, Rafael J. Wysocki wrote:
> > > > -#ifdef CONFIG_PM_SLEEP
> > > > -/**
> > > > - * acpi_pm_device_sleep_wake - Enable or disable device to wake up the system.
> > > > - * @dev: Device to enable/desible to wake up the system from sleep states.
> > > > - * @enable: Whether to enable or disable @dev to wake up the system.
> > > > - */
> > > > -int acpi_pm_device_sleep_wake(struct device *dev, bool enable)
> > > > +int acpi_pm_device_wakeup(struct device *dev, bool enable)
> > > 
> > > Can we call it acpi_pm_device_enable_wakeup() and then provide
> > > corresponding acpi_pm_device_disable_wakeup()? I find those easier to
> > > understand than acpi_pm_device_wakeup() that sounds like the device
> > > should be woken up now.
> > 
> > OK, fair enough.  I'll change it this way.
> 
> Well, sorry, I'd rather not to, or we'll have to add a wrapper around them in
> pci-acpi.c. :-)
> 
> I can rename it to acpi_pm_device_set_wakeup(), though.

Works for me :)

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web