Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1674790
| From | Mika Westerberg <mika.westerberg@linux.intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code |
| Date | 2017-06-26 15:40 +0200 |
| Message-ID | <tWCpd-2Xw-41@gated-at.bofh.it> (permalink) |
| References | <tUcIx-89O-3@gated-at.bofh.it> <tV4SC-1wt-27@gated-at.bofh.it> <tVbAL-62K-27@gated-at.bofh.it> <tVlqq-3Vc-9@gated-at.bofh.it> |
| Organization | Intel Finland Oy - BIC 0357606-4 - Westendinkatu 7, 02160 Espoo |
On Fri, Jun 23, 2017 at 03:05:57AM +0200, Rafael J. Wysocki wrote: > On Thursday, June 22, 2017 04:38:49 PM Rafael J. Wysocki wrote: > > On Thursday, June 22, 2017 10:39:37 AM Mika Westerberg wrote: > > > On Mon, Jun 19, 2017 at 11:33:52PM +0200, Rafael J. Wysocki wrote: > > > > -#ifdef CONFIG_PM_SLEEP > > > > -/** > > > > - * acpi_pm_device_sleep_wake - Enable or disable device to wake up the system. > > > > - * @dev: Device to enable/desible to wake up the system from sleep states. > > > > - * @enable: Whether to enable or disable @dev to wake up the system. > > > > - */ > > > > -int acpi_pm_device_sleep_wake(struct device *dev, bool enable) > > > > +int acpi_pm_device_wakeup(struct device *dev, bool enable) > > > > > > Can we call it acpi_pm_device_enable_wakeup() and then provide > > > corresponding acpi_pm_device_disable_wakeup()? I find those easier to > > > understand than acpi_pm_device_wakeup() that sounds like the device > > > should be woken up now. > > > > OK, fair enough. I'll change it this way. > > Well, sorry, I'd rather not to, or we'll have to add a wrapper around them in > pci-acpi.c. :-) > > I can rename it to acpi_pm_device_set_wakeup(), though. Works for me :)
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code Mika Westerberg <mika.westerberg@linux.intel.com> - 2017-06-22 09:40 +0200
Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-06-22 16:50 +0200
Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-06-23 03:20 +0200
Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code Mika Westerberg <mika.westerberg@linux.intel.com> - 2017-06-26 15:40 +0200
csiph-web