Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1660179 > unrolled thread
| Started by | Sakari Ailus <sakari.ailus@iki.fi> |
|---|---|
| First post | 2017-06-07 22:20 +0200 |
| Last post | 2017-06-10 01:50 +0200 |
| Articles | 7 — 4 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Sakari Ailus <sakari.ailus@iki.fi> - 2017-06-07 22:20 +0200
Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-06-07 22:50 +0200
Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Sakari Ailus <sakari.ailus@iki.fi> - 2017-06-07 23:20 +0200
RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 01:40 +0200
RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 02:20 +0200
Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Hans de Goede <hdegoede@redhat.com> - 2017-06-08 09:10 +0200
RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 01:50 +0200
| From | Sakari Ailus <sakari.ailus@iki.fi> |
|---|---|
| Date | 2017-06-07 22:20 +0200 |
| Subject | Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver |
| Message-ID | <tPPAS-2SK-3@gated-at.bofh.it> |
Hi Andy, On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote: > On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: > > On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote: > >> Follow the pattern, please, I suppose > >> ti_pmic_tps68470.c > > > > This pattern is weird. "ti" in front of the file name is redundant, and in > > very few places the vendor prefix is used anyway. Especially when the chip > > has a proper name --- as this one does. > > > > I assume for the Intel PMICs it could be there for a couple of reasons which > > are > > > > 1) lack of a clearly unique chip ID and > > > > 2) the use of common frameworklet for Intel PMICs. > > > > There are also no other PMIC chips supported currently. > > > > The pmic_tps68470 naming is in line with the GPIO driver (apart from the > > dash / underscore difference). > > Since > > % git ls-files *pmic* > > returns somewhat interesting results, I would even go further and use > > tps68470.c here > > and > > s/ti_pmic/tps6840/g > > inside the file. > > Would it work for you? This is still a different driver from the tps68470 driver which is an MFD driver. For clarity, I'd keep pmic as part of the name (and I'd use tps68470_pmic_ prefix for internal symbols, too). As PMICs are typically linked to the kernel (vs. being modules), there's no issue with the module name. I would suppose few if any PMICs will be compiled as modules in general. It's not a big deal though. I'm fine either way. -- Regards, Sakari Ailus e-mail: sakari.ailus@iki.fi XMPP: sailus@retiisi.org.uk
[toc] | [next] | [standalone]
| From | Andy Shevchenko <andy.shevchenko@gmail.com> |
|---|---|
| Date | 2017-06-07 22:50 +0200 |
| Subject | Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver |
| Message-ID | <tPQ3U-34T-15@gated-at.bofh.it> |
| In reply to | #1660179 |
On Wed, Jun 7, 2017 at 11:10 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: > On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote: >> On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: >> > On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote: >> >> Follow the pattern, please, I suppose >> >> ti_pmic_tps68470.c >> >> Would it work for you? > > This is still a different driver from the tps68470 driver which is an MFD > driver. For clarity, I'd keep pmic as part of the name (and I'd use > tps68470_pmic_ prefix for internal symbols, too). > > As PMICs are typically linked to the kernel (vs. being modules), there's no > issue with the module name. I would suppose few if any PMICs will be > compiled as modules in general. > > It's not a big deal though. I'm fine either way. Okay, let's agree on tps68470_pmic for internal prefix and for file name? -- With Best Regards, Andy Shevchenko
[toc] | [prev] | [next] | [standalone]
| From | Sakari Ailus <sakari.ailus@iki.fi> |
|---|---|
| Date | 2017-06-07 23:20 +0200 |
| Message-ID | <tPQwV-3ya-9@gated-at.bofh.it> |
| In reply to | #1660196 |
On Wed, Jun 07, 2017 at 11:40:27PM +0300, Andy Shevchenko wrote: > On Wed, Jun 7, 2017 at 11:10 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: > > On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote: > >> On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: > >> > On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote: > > >> >> Follow the pattern, please, I suppose > >> >> ti_pmic_tps68470.c > >> > >> Would it work for you? > > > > This is still a different driver from the tps68470 driver which is an MFD > > driver. For clarity, I'd keep pmic as part of the name (and I'd use > > tps68470_pmic_ prefix for internal symbols, too). > > > > As PMICs are typically linked to the kernel (vs. being modules), there's no > > issue with the module name. I would suppose few if any PMICs will be > > compiled as modules in general. > > > > It's not a big deal though. I'm fine either way. > > Okay, let's agree on tps68470_pmic for internal prefix and for file name? Ack. Thanks! -- Sakari Ailus e-mail: sakari.ailus@iki.fi XMPP: sailus@retiisi.org.uk
[toc] | [prev] | [next] | [standalone]
| From | "Mani, Rajmohan" <rajmohan.mani@intel.com> |
|---|---|
| Date | 2017-06-10 01:40 +0200 |
| Message-ID | <tQBFv-7Sa-1@gated-at.bofh.it> |
| In reply to | #1660234 |
Hi Sakari, Andy, > -----Original Message----- > From: Sakari Ailus [mailto:sakari.ailus@iki.fi] > Sent: Wednesday, June 07, 2017 2:13 PM > To: Andy Shevchenko <andy.shevchenko@gmail.com> > Cc: Mani, Rajmohan <rajmohan.mani@intel.com>; Hans de Goede > <hdegoede@redhat.com>; linux-kernel@vger.kernel.org; linux- > gpio@vger.kernel.org; linux-acpi@vger.kernel.org; Lee Jones > <lee.jones@linaro.org>; Linus Walleij <linus.walleij@linaro.org>; Alexandre > Courbot <gnurou@gmail.com>; Rafael J. Wysocki <rjw@rjwysocki.net>; Len > Brown <lenb@kernel.org> > Subject: Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation > region driver > > On Wed, Jun 07, 2017 at 11:40:27PM +0300, Andy Shevchenko wrote: > > On Wed, Jun 7, 2017 at 11:10 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: > > > On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote: > > >> On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: > > >> > On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote: > > > > >> >> Follow the pattern, please, I suppose ti_pmic_tps68470.c > > >> > > >> Would it work for you? > > > > > > This is still a different driver from the tps68470 driver which is > > > an MFD driver. For clarity, I'd keep pmic as part of the name (and > > > I'd use tps68470_pmic_ prefix for internal symbols, too). > > > > > > As PMICs are typically linked to the kernel (vs. being modules), > > > there's no issue with the module name. I would suppose few if any > > > PMICs will be compiled as modules in general. > > > > > > It's not a big deal though. I'm fine either way. > > > > Okay, let's agree on tps68470_pmic for internal prefix and for file name? > > Ack. Thanks! > Ack
[toc] | [prev] | [next] | [standalone]
| From | "Mani, Rajmohan" <rajmohan.mani@intel.com> |
|---|---|
| Date | 2017-06-10 02:20 +0200 |
| Message-ID | <tQCid-8lG-11@gated-at.bofh.it> |
| In reply to | #1660234 |
Hi Sakari, Andy, > Subject: Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation > region driver > > On Wed, Jun 07, 2017 at 11:40:27PM +0300, Andy Shevchenko wrote: > > On Wed, Jun 7, 2017 at 11:10 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: > > > On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote: > > >> On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: > > >> > On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote: > > > > >> >> Follow the pattern, please, I suppose ti_pmic_tps68470.c > > >> > > >> Would it work for you? > > > > > > This is still a different driver from the tps68470 driver which is > > > an MFD driver. For clarity, I'd keep pmic as part of the name (and > > > I'd use tps68470_pmic_ prefix for internal symbols, too). > > > > > > As PMICs are typically linked to the kernel (vs. being modules), > > > there's no issue with the module name. I would suppose few if any > > > PMICs will be compiled as modules in general. > > > > > > It's not a big deal though. I'm fine either way. > > > > Okay, let's agree on tps68470_pmic for internal prefix and for file name? > > Ack. Thanks! > Ack
[toc] | [prev] | [next] | [standalone]
| From | Hans de Goede <hdegoede@redhat.com> |
|---|---|
| Date | 2017-06-08 09:10 +0200 |
| Subject | Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver |
| Message-ID | <tPZJU-16j-27@gated-at.bofh.it> |
| In reply to | #1660179 |
Hi, On 07-06-17 22:10, Sakari Ailus wrote: > Hi Andy, > > On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote: >> On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote: >>> On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote: >>>> Follow the pattern, please, I suppose >>>> ti_pmic_tps68470.c >>> >>> This pattern is weird. "ti" in front of the file name is redundant, and in >>> very few places the vendor prefix is used anyway. Especially when the chip >>> has a proper name --- as this one does. >>> >>> I assume for the Intel PMICs it could be there for a couple of reasons which >>> are >>> >>> 1) lack of a clearly unique chip ID and >>> >>> 2) the use of common frameworklet for Intel PMICs. >>> >>> There are also no other PMIC chips supported currently. >>> >>> The pmic_tps68470 naming is in line with the GPIO driver (apart from the >>> dash / underscore difference). >> >> Since >> >> % git ls-files *pmic* >> >> returns somewhat interesting results, I would even go further and use >> >> tps68470.c here >> >> and >> >> s/ti_pmic/tps6840/g >> >> inside the file. >> >> Would it work for you? > > This is still a different driver from the tps68470 driver which is an MFD > driver. For clarity, I'd keep pmic as part of the name (and I'd use > tps68470_pmic_ prefix for internal symbols, too). > > As PMICs are typically linked to the kernel (vs. being modules), there's no > issue with the module name. I would suppose few if any PMICs will be > compiled as modules in general. Good point about the OpRegion driver usually being built-in, in my experience it MUST always be built-in, so the Kconfig option should be a bool. Note this is useless unless the mfd driver is also a bool (I would advice to go that route) and the mfd driver's Kconfig should select the right i2c bus driver to make sure that is built-in too, see for example: https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for-mfd-next&id=2f91ded5f8f4fdd67d8daae514b0d434c98ab1e0 https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for-mfd-next&id=c5065d8625ebdc164199b99d838ac0636faa7f0b https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for-mfd-next&id=5f125f1f570568a29edf783fba1ebb606d5c6b24 Which are all recent commits from me dealing with making the mfd driver built-in / selecting the i2c bus driver. Regards, Hans
[toc] | [prev] | [next] | [standalone]
| From | "Mani, Rajmohan" <rajmohan.mani@intel.com> |
|---|---|
| Date | 2017-06-10 01:50 +0200 |
| Message-ID | <tQBPb-7Vf-1@gated-at.bofh.it> |
| In reply to | #1660811 |
Hi Hans, > > > > As PMICs are typically linked to the kernel (vs. being modules), > > there's no issue with the module name. I would suppose few if any > > PMICs will be compiled as modules in general. > > Good point about the OpRegion driver usually being built-in, in my experience it > MUST always be built-in, so the Kconfig option should be a bool. Note this is > useless unless the mfd driver is also a bool (I would advice to go that > route) and the mfd driver's Kconfig should select the right i2c bus driver to > make sure that is built-in too, see for example: > > https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for- > mfd-next&id=2f91ded5f8f4fdd67d8daae514b0d434c98ab1e0 > https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for- > mfd-next&id=c5065d8625ebdc164199b99d838ac0636faa7f0b > https://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git/commit/?h=for- > mfd-next&id=5f125f1f570568a29edf783fba1ebb606d5c6b24 > > Which are all recent commits from me dealing with making the mfd driver built- > in / selecting the i2c bus driver. > Thanks for these links. I will update the Kconfig and commit messages with relevant description around this.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web