Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1660179

Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver

From Sakari Ailus <sakari.ailus@iki.fi>
Newsgroups linux.kernel
Subject Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver
Date 2017-06-07 22:20 +0200
Message-ID <tPPAS-2SK-3@gated-at.bofh.it> (permalink)
References <tPlt8-aF-9@gated-at.bofh.it> <tPlt9-aF-31@gated-at.bofh.it> <tPnEB-1x7-3@gated-at.bofh.it> <tPI6m-6wb-13@gated-at.bofh.it> <tPJvs-7jj-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi Andy,

On Wed, Jun 07, 2017 at 04:40:13PM +0300, Andy Shevchenko wrote:
> On Wed, Jun 7, 2017 at 3:15 PM, Sakari Ailus <sakari.ailus@iki.fi> wrote:
> > On Tue, Jun 06, 2017 at 05:23:56PM +0300, Andy Shevchenko wrote:
> >> Follow the pattern, please, I suppose
> >> ti_pmic_tps68470.c
> >
> > This pattern is weird. "ti" in front of the file name is redundant, and in
> > very few places the vendor prefix is used anyway. Especially when the chip
> > has a proper name --- as this one does.
> >
> > I assume for the Intel PMICs it could be there for a couple of reasons which
> > are
> >
> > 1) lack of a clearly unique chip ID and
> >
> > 2) the use of common frameworklet for Intel PMICs.
> >
> > There are also no other PMIC chips supported currently.
> >
> > The pmic_tps68470 naming is in line with the GPIO driver (apart from the
> > dash / underscore difference).
> 
> Since
> 
> % git ls-files *pmic*
> 
> returns somewhat interesting results, I would even go further and use
> 
> tps68470.c here
> 
> and
> 
> s/ti_pmic/tps6840/g
> 
> inside the file.
> 
> Would it work for you?

This is still a different driver from the tps68470 driver which is an MFD
driver. For clarity, I'd keep pmic as part of the name (and I'd use
tps68470_pmic_ prefix for internal symbols, too).

As PMICs are typically linked to the kernel (vs. being modules), there's no
issue with the module name. I would suppose few if any PMICs will be
compiled as modules in general.

It's not a big deal though. I'm fine either way.

-- 
Regards,

Sakari Ailus
e-mail: sakari.ailus@iki.fi	XMPP: sailus@retiisi.org.uk

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v1 0/3] TPS68470 PMIC drivers  Rajmohan Mani <rajmohan.mani@intel.com> - 2017-06-06 14:10 +0200
  [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Rajmohan Mani <rajmohan.mani@intel.com> - 2017-06-06 14:10 +0200
    Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-06-06 16:30 +0200
      Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region  driver Hans de Goede <hdegoede@redhat.com> - 2017-06-06 17:30 +0200
        RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 00:30 +0200
      Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver Sakari Ailus <sakari.ailus@iki.fi> - 2017-06-07 14:20 +0200
        Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-06-07 15:50 +0200
          Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver Sakari Ailus <sakari.ailus@iki.fi> - 2017-06-07 22:20 +0200
            Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-06-07 22:50 +0200
              Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver Sakari Ailus <sakari.ailus@iki.fi> - 2017-06-07 23:20 +0200
                RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 01:40 +0200
                RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 02:20 +0200
            Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region  driver Hans de Goede <hdegoede@redhat.com> - 2017-06-08 09:10 +0200
              RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 01:50 +0200
      RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 00:30 +0200
    Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver Sakari Ailus <sakari.ailus@iki.fi> - 2017-06-07 14:10 +0200
      Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation region driver Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-06-07 15:40 +0200
        Re: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver Sakari Ailus <sakari.ailus@iki.fi> - 2017-06-07 22:10 +0200
          RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 02:10 +0200
        RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 02:10 +0200
      RE: [PATCH v1 3/3] ACPI / PMIC: Add TI PMIC TPS68470 operation  region driver "Mani, Rajmohan" <rajmohan.mani@intel.com> - 2017-06-10 02:10 +0200

csiph-web