Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1554582 > unrolled thread

Re: [PATCH 0/2] sched: Introduce rcuwait

Started byDavidlohr Bueso <dave@stgolabs.net>
First post2017-01-09 19:30 +0100
Last post2017-01-10 20:40 +0100
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 0/2] sched: Introduce rcuwait Davidlohr Bueso <dave@stgolabs.net> - 2017-01-09 19:30 +0100
    Re: [PATCH 0/2] sched: Introduce rcuwait Oleg Nesterov <oleg@redhat.com> - 2017-01-10 19:40 +0100
      Re: [PATCH 0/2] sched: Introduce rcuwait Davidlohr Bueso <dave@stgolabs.net> - 2017-01-10 20:40 +0100

#1554582 — Re: [PATCH 0/2] sched: Introduce rcuwait

FromDavidlohr Bueso <dave@stgolabs.net>
Date2017-01-09 19:30 +0100
SubjectRe: [PATCH 0/2] sched: Introduce rcuwait
Message-ID<sXMRH-7CY-3@gated-at.bofh.it>
Gents, any further thoughts on this?

Thanks,
Davidlohr

[toc] | [next] | [standalone]


#1555797

FromOleg Nesterov <oleg@redhat.com>
Date2017-01-10 19:40 +0100
Message-ID<sY9uV-4ME-7@gated-at.bofh.it>
In reply to#1554582
On 01/09, Davidlohr Bueso wrote:
>
> Gents, any further thoughts on this?

Both look correct to me, and I think this allows us to make more
optimizations in percpu-rwsem.c.


I am not sure about the naming... Yes, it relies on rcu but this is
just implementation detail. But this is cosmetic and I can't suggest
something better than rcuwait.

Well, speaking of naming, rcuwait_trywake() doesn't look good to me,
rcuwait_wake_up() looks better, "try" is misleading imo. But this is
cosmetic/subjective too.


Reviewed-by: Oleg Nesterov <oleg@redhat.com>

[toc] | [prev] | [next] | [standalone]


#1555867

FromDavidlohr Bueso <dave@stgolabs.net>
Date2017-01-10 20:40 +0100
Message-ID<sYar1-5m6-61@gated-at.bofh.it>
In reply to#1555797
On Tue, 10 Jan 2017, Oleg Nesterov wrote:

>Well, speaking of naming, rcuwait_trywake() doesn't look good to me,
>rcuwait_wake_up() looks better, "try" is misleading imo. But this is
>cosmetic/subjective too.

I actually added the 'try' on second thought -- in that for the particular
pcpu-rwsem user, obviously most of the time the wakeup will not actually
occur. But yeah, I'd have no problem just naming it rcuwait_wake_up().

>Reviewed-by: Oleg Nesterov <oleg@redhat.com>

Thanks!

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web