Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1555867

Re: [PATCH 0/2] sched: Introduce rcuwait

From Davidlohr Bueso <dave@stgolabs.net>
Newsgroups linux.kernel
Subject Re: [PATCH 0/2] sched: Introduce rcuwait
Date 2017-01-10 20:40 +0100
Message-ID <sYar1-5m6-61@gated-at.bofh.it> (permalink)
References <sRf2p-3NJ-3@gated-at.bofh.it> <sXMRH-7CY-3@gated-at.bofh.it> <sY9uV-4ME-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, 10 Jan 2017, Oleg Nesterov wrote:

>Well, speaking of naming, rcuwait_trywake() doesn't look good to me,
>rcuwait_wake_up() looks better, "try" is misleading imo. But this is
>cosmetic/subjective too.

I actually added the 'try' on second thought -- in that for the particular
pcpu-rwsem user, obviously most of the time the wakeup will not actually
occur. But yeah, I'd have no problem just naming it rcuwait_wake_up().

>Reviewed-by: Oleg Nesterov <oleg@redhat.com>

Thanks!

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH 0/2] sched: Introduce rcuwait Davidlohr Bueso <dave@stgolabs.net> - 2017-01-09 19:30 +0100
  Re: [PATCH 0/2] sched: Introduce rcuwait Oleg Nesterov <oleg@redhat.com> - 2017-01-10 19:40 +0100
    Re: [PATCH 0/2] sched: Introduce rcuwait Davidlohr Bueso <dave@stgolabs.net> - 2017-01-10 20:40 +0100

csiph-web