Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1555797

Re: [PATCH 0/2] sched: Introduce rcuwait

From Oleg Nesterov <oleg@redhat.com>
Newsgroups linux.kernel
Subject Re: [PATCH 0/2] sched: Introduce rcuwait
Date 2017-01-10 19:40 +0100
Message-ID <sY9uV-4ME-7@gated-at.bofh.it> (permalink)
References <sRf2p-3NJ-3@gated-at.bofh.it> <sXMRH-7CY-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 01/09, Davidlohr Bueso wrote:
>
> Gents, any further thoughts on this?

Both look correct to me, and I think this allows us to make more
optimizations in percpu-rwsem.c.


I am not sure about the naming... Yes, it relies on rcu but this is
just implementation detail. But this is cosmetic and I can't suggest
something better than rcuwait.

Well, speaking of naming, rcuwait_trywake() doesn't look good to me,
rcuwait_wake_up() looks better, "try" is misleading imo. But this is
cosmetic/subjective too.


Reviewed-by: Oleg Nesterov <oleg@redhat.com>

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH 0/2] sched: Introduce rcuwait Davidlohr Bueso <dave@stgolabs.net> - 2017-01-09 19:30 +0100
  Re: [PATCH 0/2] sched: Introduce rcuwait Oleg Nesterov <oleg@redhat.com> - 2017-01-10 19:40 +0100
    Re: [PATCH 0/2] sched: Introduce rcuwait Davidlohr Bueso <dave@stgolabs.net> - 2017-01-10 20:40 +0100

csiph-web