Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1455271 > unrolled thread
| Started by | Baole Ni <baolex.ni@intel.com> |
|---|---|
| First post | 2016-08-02 20:10 +0200 |
| Last post | 2016-08-02 22:40 +0200 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH 0157/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 20:10 +0200
Re: [PATCH 0157/1285] Replace numeric parameter like 0444 with macro Olof Johansson <olof@lixom.net> - 2016-08-02 21:10 +0200
Re: [PATCH 0157/1285] Replace numeric parameter like 0444 with macro Segher Boessenkool <segher@kernel.crashing.org> - 2016-08-02 22:40 +0200
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Date | 2016-08-02 20:10 +0200 |
| Subject | [PATCH 0157/1285] Replace numeric parameter like 0444 with macro |
| Message-ID | <s1MiE-84F-121@gated-at.bofh.it> |
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
drivers/edac/pasemi_edac.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/edac/pasemi_edac.c b/drivers/edac/pasemi_edac.c
index 9c971b5..8150e95 100644
--- a/drivers/edac/pasemi_edac.c
+++ b/drivers/edac/pasemi_edac.c
@@ -310,6 +310,6 @@ module_exit(pasemi_edac_exit);
MODULE_LICENSE("GPL");
MODULE_AUTHOR("Egor Martovetsky <egor@pasemi.com>");
MODULE_DESCRIPTION("MC support for PA Semi PWRficient memory controller");
-module_param(edac_op_state, int, 0444);
+module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI");
--
2.9.2
[toc] | [next] | [standalone]
| From | Olof Johansson <olof@lixom.net> |
|---|---|
| Date | 2016-08-02 21:10 +0200 |
| Message-ID | <s1NeG-gB-47@gated-at.bofh.it> |
| In reply to | #1455271 |
On Tue, Aug 02, 2016 at 06:45:15PM +0800, Baole Ni wrote: > I find that the developers often just specified the numeric value > when calling a macro which is defined with a parameter for access permission. > As we know, these numeric value for access permission have had the corresponding macro, > and that using macro can improve the robustness and readability of the code, > thus, I suggest replacing the numeric parameter with the macro. Am I the only one who find the readability to be MUCH better for the numeric values? -Olof
[toc] | [prev] | [next] | [standalone]
| From | Segher Boessenkool <segher@kernel.crashing.org> |
|---|---|
| Date | 2016-08-02 22:40 +0200 |
| Message-ID | <s1ODL-16D-17@gated-at.bofh.it> |
| In reply to | #1455410 |
On Tue, Aug 02, 2016 at 11:54:47AM -0700, Olof Johansson wrote: > On Tue, Aug 02, 2016 at 06:45:15PM +0800, Baole Ni wrote: > > I find that the developers often just specified the numeric value > > when calling a macro which is defined with a parameter for access permission. > > As we know, these numeric value for access permission have had the corresponding macro, > > and that using macro can improve the robustness and readability of the code, > > thus, I suggest replacing the numeric parameter with the macro. > > Am I the only one who find the readability to be MUCH better for the > numeric values? You are not the only one. Robustness is a non-issue here as well (except that this patch series showed that some mail servers struggle to handle 1285 emails). Segher
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web