Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1455271
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0157/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-02 20:10 +0200 |
| Message-ID | <s1MiE-84F-121@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
drivers/edac/pasemi_edac.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/edac/pasemi_edac.c b/drivers/edac/pasemi_edac.c
index 9c971b5..8150e95 100644
--- a/drivers/edac/pasemi_edac.c
+++ b/drivers/edac/pasemi_edac.c
@@ -310,6 +310,6 @@ module_exit(pasemi_edac_exit);
MODULE_LICENSE("GPL");
MODULE_AUTHOR("Egor Martovetsky <egor@pasemi.com>");
MODULE_DESCRIPTION("MC support for PA Semi PWRficient memory controller");
-module_param(edac_op_state, int, 0444);
+module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI");
--
2.9.2
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0157/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 20:10 +0200
Re: [PATCH 0157/1285] Replace numeric parameter like 0444 with macro Olof Johansson <olof@lixom.net> - 2016-08-02 21:10 +0200
Re: [PATCH 0157/1285] Replace numeric parameter like 0444 with macro Segher Boessenkool <segher@kernel.crashing.org> - 2016-08-02 22:40 +0200
csiph-web