Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1455203 > unrolled thread

Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro

Started byPavel Machek <pavel@ucw.cz>
First post2016-08-02 19:50 +0200
Last post2016-08-02 20:00 +0200
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro Pavel Machek <pavel@ucw.cz> - 2016-08-02 19:50 +0200
    Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro Pavel Machek <pavel@ucw.cz> - 2016-08-02 20:00 +0200
    Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro Joe Perches <joe@perches.com> - 2016-08-02 20:00 +0200

#1455203 — Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro

FromPavel Machek <pavel@ucw.cz>
Date2016-08-02 19:50 +0200
SubjectRe: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro
Message-ID<s1LZh-7Ht-61@gated-at.bofh.it>
Hi!

> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.

> -core_param(no_bL_switcher, no_bL_switcher, bool, 0644);
> +core_param(no_bL_switcher, no_bL_switcher, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);

Everyone knows what 0644 is, but noone can read S_IRUSR | S_IWUSR |
S_IRCRP | S_IROTH (*). Please don't do this.

									Pavel
















































(*) I deliberately included an error there. Did you spot the error?
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

[toc] | [next] | [standalone]


#1455207

FromPavel Machek <pavel@ucw.cz>
Date2016-08-02 20:00 +0200
Message-ID<s1M8V-7Lb-1@gated-at.bofh.it>
In reply to#1455203
On Tue 2016-08-02 10:52:18, Joe Perches wrote:
> On Tue, 2016-08-02 at 19:42 +0200, Pavel Machek wrote:
> > > I find that the developers often just specified the numeric value
> > > when calling a macro which is defined with a parameter for access permission.
> > > As we know, these numeric value for access permission have had the corresponding macro,
> > > and that using macro can improve the robustness and readability of the code,
> > > thus, I suggest replacing the numeric parameter with the macro.
> > > 
> > > -core_param(no_bL_switcher, no_bL_switcher, bool, 0644);
> > > +core_param(no_bL_switcher, no_bL_switcher, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
> 
> > Everyone knows what 0644 is, but noone can read S_IRUSR | S_IWUSR |
> > S_IRCRP | S_IROTH (*). Please don't do this.
> 
> Perhaps this conversion is best done in reverse with
> most all of the S_[A-Z]{5,5} uses converted to octal.

I'd prefer that, yes.. But lets discuss that before another 1200 patch
patchbomb...

									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

[toc] | [prev] | [next] | [standalone]


#1455225

FromJoe Perches <joe@perches.com>
Date2016-08-02 20:00 +0200
Message-ID<s1M8V-7Lb-3@gated-at.bofh.it>
In reply to#1455203
On Tue, 2016-08-02 at 19:42 +0200, Pavel Machek wrote:
> > I find that the developers often just specified the numeric value
> > when calling a macro which is defined with a parameter for access permission.
> > As we know, these numeric value for access permission have had the corresponding macro,
> > and that using macro can improve the robustness and readability of the code,
> > thus, I suggest replacing the numeric parameter with the macro.
> > 
> > -core_param(no_bL_switcher, no_bL_switcher, bool, 0644);
> > +core_param(no_bL_switcher, no_bL_switcher, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);

> Everyone knows what 0644 is, but noone can read S_IRUSR | S_IWUSR |
> S_IRCRP | S_IROTH (*). Please don't do this.

Perhaps this conversion is best done in reverse with
most all of the S_[A-Z]{5,5} uses converted to octal.

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web