Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1455203
| From | Pavel Machek <pavel@ucw.cz> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-02 19:50 +0200 |
| Message-ID | <s1LZh-7Ht-61@gated-at.bofh.it> (permalink) |
| References | <s1HVF-50V-81@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi! > I find that the developers often just specified the numeric value > when calling a macro which is defined with a parameter for access permission. > As we know, these numeric value for access permission have had the corresponding macro, > and that using macro can improve the robustness and readability of the code, > thus, I suggest replacing the numeric parameter with the macro. > -core_param(no_bL_switcher, no_bL_switcher, bool, 0644); > +core_param(no_bL_switcher, no_bL_switcher, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); Everyone knows what 0644 is, but noone can read S_IRUSR | S_IWUSR | S_IRCRP | S_IROTH (*). Please don't do this. Pavel (*) I deliberately included an error there. Did you spot the error? -- (english) http://www.livejournal.com/~pavelmachek (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro Pavel Machek <pavel@ucw.cz> - 2016-08-02 19:50 +0200 Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro Pavel Machek <pavel@ucw.cz> - 2016-08-02 20:00 +0200 Re: [PATCH 0001/1285] Replace numeric parameter like 0444 with macro Joe Perches <joe@perches.com> - 2016-08-02 20:00 +0200
csiph-web