Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1352947 > unrolled thread
| Started by | Laxman Dewangan <ldewangan@nvidia.com> |
|---|---|
| First post | 2016-03-08 13:20 +0100 |
| Last post | 2016-03-10 08:20 +0100 |
| Articles | 6 — 4 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed Laxman Dewangan <ldewangan@nvidia.com> - 2016-03-08 13:20 +0100
Re: [PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed Vladimir Zapolskiy <vladimir_zapolskiy@mentor.com> - 2016-03-08 13:30 +0100
Re: [PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed Thierry Reding <treding@nvidia.com> - 2016-03-08 15:30 +0100
Re: [PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed Laxman Dewangan <ldewangan@nvidia.com> - 2016-03-08 16:50 +0100
Re: [PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed Stephen Warren <swarren@wwwdotorg.org> - 2016-03-09 18:10 +0100
Re: [PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed Laxman Dewangan <ldewangan@nvidia.com> - 2016-03-10 08:20 +0100
| From | Laxman Dewangan <ldewangan@nvidia.com> |
|---|---|
| Date | 2016-03-08 13:20 +0100 |
| Subject | [PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed |
| Message-ID | <raoMi-Hp-9@gated-at.bofh.it> |
Print the error number of GPIO hog failed during
its configurations. This helps in identifying the
failure without instrumenting the code.
Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
---
drivers/gpio/gpiolib.c | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
index bc788b9..7575ebb 100644
--- a/drivers/gpio/gpiolib.c
+++ b/drivers/gpio/gpiolib.c
@@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name,
local_desc = gpiochip_request_own_desc(chip, hwnum, name);
if (IS_ERR(local_desc)) {
- pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
- name, chip->label, hwnum);
+ status = PTR_ERR(local_desc);
+ pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
+ name, chip->label, hwnum, status);
return PTR_ERR(local_desc);
}
status = gpiod_configure_flags(desc, name, dflags);
if (status < 0) {
- pr_err("setup of hog GPIO %s (chip %s, offset %d) failed\n",
- name, chip->label, hwnum);
+ pr_err("setup of hog GPIO %s chip %s, offset %d failed %d\n",
+ name, chip->label, hwnum, status);
gpiochip_free_own_desc(desc);
return status;
}
--
2.1.4
[toc] | [next] | [standalone]
| From | Vladimir Zapolskiy <vladimir_zapolskiy@mentor.com> |
|---|---|
| Date | 2016-03-08 13:30 +0100 |
| Message-ID | <raoVY-Mw-11@gated-at.bofh.it> |
| In reply to | #1352947 |
On 08.03.2016 14:02, Laxman Dewangan wrote:
> Print the error number of GPIO hog failed during
> its configurations. This helps in identifying the
> failure without instrumenting the code.
>
> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
> ---
> drivers/gpio/gpiolib.c | 9 +++++----
> 1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index bc788b9..7575ebb 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name,
>
> local_desc = gpiochip_request_own_desc(chip, hwnum, name);
> if (IS_ERR(local_desc)) {
> - pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
> - name, chip->label, hwnum);
> + status = PTR_ERR(local_desc);
> + pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
> + name, chip->label, hwnum, status);
> return PTR_ERR(local_desc);
You can do "return status;" now.
> }
>
> status = gpiod_configure_flags(desc, name, dflags);
> if (status < 0) {
> - pr_err("setup of hog GPIO %s (chip %s, offset %d) failed\n",
> - name, chip->label, hwnum);
> + pr_err("setup of hog GPIO %s chip %s, offset %d failed %d\n",
> + name, chip->label, hwnum, status);
> gpiochip_free_own_desc(desc);
> return status;
> }
>
--
With best wishes,
Vladimir
[toc] | [prev] | [next] | [standalone]
| From | Thierry Reding <treding@nvidia.com> |
|---|---|
| Date | 2016-03-08 15:30 +0100 |
| Message-ID | <raqO6-21z-7@gated-at.bofh.it> |
| In reply to | #1352947 |
[Multipart message — attachments visible in raw view] — view raw
On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
> Print the error number of GPIO hog failed during
> its configurations. This helps in identifying the
> failure without instrumenting the code.
Please use up all 72 characters per line at your disposal. Excessively
short lines are hard to read.
> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
> ---
> drivers/gpio/gpiolib.c | 9 +++++----
> 1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index bc788b9..7575ebb 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name,
>
> local_desc = gpiochip_request_own_desc(chip, hwnum, name);
> if (IS_ERR(local_desc)) {
> - pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
> - name, chip->label, hwnum);
> + status = PTR_ERR(local_desc);
> + pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
> + name, chip->label, hwnum, status);
I find this type of format hard to read. I prefer a semi-colon to
separate the message from the failure reason (i.e. error code).
Besides that I don't understand why you're dropping the parentheses
around the "chip %s, offset %d", I found that easier on the eye.
Thierry
[toc] | [prev] | [next] | [standalone]
| From | Laxman Dewangan <ldewangan@nvidia.com> |
|---|---|
| Date | 2016-03-08 16:50 +0100 |
| Message-ID | <ras3w-2Le-27@gated-at.bofh.it> |
| In reply to | #1353095 |
On Tuesday 08 March 2016 07:52 PM, Thierry Reding wrote:
> On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
>
>> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
>> ---
>> drivers/gpio/gpiolib.c | 9 +++++----
>> 1 file changed, 5 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
>> index bc788b9..7575ebb 100644
>> --- a/drivers/gpio/gpiolib.c
>> +++ b/drivers/gpio/gpiolib.c
>> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name,
>>
>> local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>> if (IS_ERR(local_desc)) {
>> - pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
>> - name, chip->label, hwnum);
>> + status = PTR_ERR(local_desc);
>> + pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
>> + name, chip->label, hwnum, status);
> I find this type of format hard to read. I prefer a semi-colon to
> separate the message from the failure reason (i.e. error code).
>
> Besides that I don't understand why you're dropping the parentheses
> around the "chip %s, offset %d", I found that easier on the eye.
>
>
I did to accommodate the 3 extra character ( %d) for string format on
that line as it was already near to 80 column.
Just did not want to split in multiple lines.
[toc] | [prev] | [next] | [standalone]
| From | Stephen Warren <swarren@wwwdotorg.org> |
|---|---|
| Date | 2016-03-09 18:10 +0100 |
| Message-ID | <raPMv-2zP-29@gated-at.bofh.it> |
| In reply to | #1353161 |
On 03/08/2016 08:32 AM, Laxman Dewangan wrote:
>
> On Tuesday 08 March 2016 07:52 PM, Thierry Reding wrote:
>> On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
>>
>>> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
>>> ---
>>> drivers/gpio/gpiolib.c | 9 +++++----
>>> 1 file changed, 5 insertions(+), 4 deletions(-)
>>>
>>> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
>>> index bc788b9..7575ebb 100644
>>> --- a/drivers/gpio/gpiolib.c
>>> +++ b/drivers/gpio/gpiolib.c
>>> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const
>>> char *name,
>>> local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>>> if (IS_ERR(local_desc)) {
>>> - pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
>>> - name, chip->label, hwnum);
>>> + status = PTR_ERR(local_desc);
>>> + pr_err("requesting hog GPIO %s, chip %s, offset %d failed
>>> %d\n",
>>> + name, chip->label, hwnum, status);
>> I find this type of format hard to read. I prefer a semi-colon to
>> separate the message from the failure reason (i.e. error code).
>>
>> Besides that I don't understand why you're dropping the parentheses
>> around the "chip %s, offset %d", I found that easier on the eye.
>
> I did to accommodate the 3 extra character ( %d) for string format on
> that line as it was already near to 80 column.
> Just did not want to split in multiple lines.
Note that strings shouldn't be split across lines since it makes it
harder to grep for them. This is one case where the 80-column limit
isn't strict, within reason.
[toc] | [prev] | [next] | [standalone]
| From | Laxman Dewangan <ldewangan@nvidia.com> |
|---|---|
| Date | 2016-03-10 08:20 +0100 |
| Message-ID | <rb334-3w5-19@gated-at.bofh.it> |
| In reply to | #1354286 |
On Wednesday 09 March 2016 10:37 PM, Stephen Warren wrote:
> On 03/08/2016 08:32 AM, Laxman Dewangan wrote:
>>
>> On Tuesday 08 March 2016 07:52 PM, Thierry Reding wrote:
>>> On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
>>>
>>>> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
>>>> ---
>>>> drivers/gpio/gpiolib.c | 9 +++++----
>>>> 1 file changed, 5 insertions(+), 4 deletions(-)
>>>>
>>>> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
>>>> index bc788b9..7575ebb 100644
>>>> --- a/drivers/gpio/gpiolib.c
>>>> +++ b/drivers/gpio/gpiolib.c
>>>> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const
>>>> char *name,
>>>> local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>>>> if (IS_ERR(local_desc)) {
>>>> - pr_err("requesting hog GPIO %s (chip %s, offset %d)
>>>> failed\n",
>>>> - name, chip->label, hwnum);
>>>> + status = PTR_ERR(local_desc);
>>>> + pr_err("requesting hog GPIO %s, chip %s, offset %d failed
>>>> %d\n",
>>>> + name, chip->label, hwnum, status);
>>> I find this type of format hard to read. I prefer a semi-colon to
>>> separate the message from the failure reason (i.e. error code).
>>>
>>> Besides that I don't understand why you're dropping the parentheses
>>> around the "chip %s, offset %d", I found that easier on the eye.
>>
>> I did to accommodate the 3 extra character ( %d) for string format on
>> that line as it was already near to 80 column.
>> Just did not want to split in multiple lines.
>
> Note that strings shouldn't be split across lines since it makes it
> harder to grep for them. This is one case where the 80-column limit
> isn't strict, within reason.
OK, so not change the existing string, just add new format.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web