Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1433832 > unrolled thread
| Started by | Amitoj Kaur Chawla <amitoj1606@gmail.com> |
|---|---|
| First post | 2016-06-29 17:00 +0200 |
| Last post | 2016-06-30 08:40 +0200 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH] ALSA: riptide: Use DIV_ROUND_UP Amitoj Kaur Chawla <amitoj1606@gmail.com> - 2016-06-29 17:00 +0200
Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP Takashi Sakamoto <o-takashi@sakamocchi.jp> - 2016-06-30 04:20 +0200
Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP Takashi Iwai <tiwai@suse.de> - 2016-06-30 08:40 +0200
| From | Amitoj Kaur Chawla <amitoj1606@gmail.com> |
|---|---|
| Date | 2016-06-29 17:00 +0200 |
| Subject | [PATCH] ALSA: riptide: Use DIV_ROUND_UP |
| Message-ID | <rPp85-5s5-23@gated-at.bofh.it> |
The kernel.h macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /(d)) but is perhaps more readable. The Coccinelle script used to make this change is as follows: @haskernel@ @@ #include <linux/kernel.h> @depends on haskernel@ expression n,d; @@ ( - (n + d - 1) / d + DIV_ROUND_UP(n,d) | - (n + (d - 1)) / d + DIV_ROUND_UP(n,d) ) Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com> --- sound/pci/riptide/riptide.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/pci/riptide/riptide.c b/sound/pci/riptide/riptide.c index 94639d6..067a912 100644 --- a/sound/pci/riptide/riptide.c +++ b/sound/pci/riptide/riptide.c @@ -1496,7 +1496,7 @@ static int snd_riptide_prepare(struct snd_pcm_substream *substream) f = PAGE_SIZE; while ((size + (f >> 1) - 1) <= (f << 7) && (f << 1) > period) f = f >> 1; - pages = (size + f - 1) / f; + pages = DIV_ROUND_UP(size, f); data->size = size; data->pages = pages; snd_printdd -- 1.9.1
[toc] | [next] | [standalone]
| From | Takashi Sakamoto <o-takashi@sakamocchi.jp> |
|---|---|
| Date | 2016-06-30 04:20 +0200 |
| Message-ID | <rPzK9-3Lo-3@gated-at.bofh.it> |
| In reply to | #1433832 |
On Jun 29 2016 23:56, Amitoj Kaur Chawla wrote: > The kernel.h macro DIV_ROUND_UP performs the computation > (((n) + (d) - 1) /(d)) but is perhaps more readable. > > The Coccinelle script used to make this change is as follows: > @haskernel@ > @@ > > #include <linux/kernel.h> > > @depends on haskernel@ > expression n,d; > @@ > > ( > - (n + d - 1) / d > + DIV_ROUND_UP(n,d) > | > - (n + (d - 1)) / d > + DIV_ROUND_UP(n,d) > ) > > Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com> > --- > sound/pci/riptide/riptide.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/sound/pci/riptide/riptide.c b/sound/pci/riptide/riptide.c > index 94639d6..067a912 100644 > --- a/sound/pci/riptide/riptide.c > +++ b/sound/pci/riptide/riptide.c > @@ -1496,7 +1496,7 @@ static int snd_riptide_prepare(struct snd_pcm_substream *substream) > f = PAGE_SIZE; > while ((size + (f >> 1) - 1) <= (f << 7) && (f << 1) > period) > f = f >> 1; > - pages = (size + f - 1) / f; > + pages = DIV_ROUND_UP(size, f); > data->size = size; > data->pages = pages; > snd_printdd > Reviewed-by: Takashi Sakamoto <o-takashi@sakamocchi.jp> Regards Takashi Sakamoto
[toc] | [prev] | [next] | [standalone]
| From | Takashi Iwai <tiwai@suse.de> |
|---|---|
| Date | 2016-06-30 08:40 +0200 |
| Message-ID | <rPDNM-6av-13@gated-at.bofh.it> |
| In reply to | #1433832 |
On Wed, 29 Jun 2016 16:56:28 +0200, Amitoj Kaur Chawla wrote: > > The kernel.h macro DIV_ROUND_UP performs the computation > (((n) + (d) - 1) /(d)) but is perhaps more readable. > > The Coccinelle script used to make this change is as follows: > @haskernel@ > @@ > > #include <linux/kernel.h> > > @depends on haskernel@ > expression n,d; > @@ > > ( > - (n + d - 1) / d > + DIV_ROUND_UP(n,d) > | > - (n + (d - 1)) / d > + DIV_ROUND_UP(n,d) > ) > > Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com> Applied, thanks. Takashi
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web