Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1434180

Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP

From Takashi Sakamoto <o-takashi@sakamocchi.jp>
Newsgroups linux.kernel
Subject Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP
Date 2016-06-30 04:20 +0200
Message-ID <rPzK9-3Lo-3@gated-at.bofh.it> (permalink)
References <rPp85-5s5-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Jun 29 2016 23:56, Amitoj Kaur Chawla wrote:
> The kernel.h macro DIV_ROUND_UP performs the computation
> (((n) + (d) - 1) /(d)) but is perhaps more readable.
>
> The Coccinelle script used to make this change is as follows:
> @haskernel@
> @@
>
> #include <linux/kernel.h>
>
> @depends on haskernel@
> expression n,d;
> @@
>
> (
> - (n + d - 1) / d
> + DIV_ROUND_UP(n,d)
> |
> - (n + (d - 1)) / d
> + DIV_ROUND_UP(n,d)
> )
>
> Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com>
> ---
>   sound/pci/riptide/riptide.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/sound/pci/riptide/riptide.c b/sound/pci/riptide/riptide.c
> index 94639d6..067a912 100644
> --- a/sound/pci/riptide/riptide.c
> +++ b/sound/pci/riptide/riptide.c
> @@ -1496,7 +1496,7 @@ static int snd_riptide_prepare(struct snd_pcm_substream *substream)
>   		f = PAGE_SIZE;
>   		while ((size + (f >> 1) - 1) <= (f << 7) && (f << 1) > period)
>   			f = f >> 1;
> -		pages = (size + f - 1) / f;
> +		pages = DIV_ROUND_UP(size, f);
>   		data->size = size;
>   		data->pages = pages;
>   		snd_printdd
>

Reviewed-by: Takashi Sakamoto <o-takashi@sakamocchi.jp>


Regards

Takashi Sakamoto

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] ALSA: riptide: Use DIV_ROUND_UP Amitoj Kaur Chawla <amitoj1606@gmail.com> - 2016-06-29 17:00 +0200
  Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP Takashi Sakamoto <o-takashi@sakamocchi.jp> - 2016-06-30 04:20 +0200
  Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP Takashi Iwai <tiwai@suse.de> - 2016-06-30 08:40 +0200

csiph-web