Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1434250
| From | Takashi Iwai <tiwai@suse.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP |
| Date | 2016-06-30 08:40 +0200 |
| Message-ID | <rPDNM-6av-13@gated-at.bofh.it> (permalink) |
| References | <rPp85-5s5-23@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, 29 Jun 2016 16:56:28 +0200, Amitoj Kaur Chawla wrote: > > The kernel.h macro DIV_ROUND_UP performs the computation > (((n) + (d) - 1) /(d)) but is perhaps more readable. > > The Coccinelle script used to make this change is as follows: > @haskernel@ > @@ > > #include <linux/kernel.h> > > @depends on haskernel@ > expression n,d; > @@ > > ( > - (n + d - 1) / d > + DIV_ROUND_UP(n,d) > | > - (n + (d - 1)) / d > + DIV_ROUND_UP(n,d) > ) > > Signed-off-by: Amitoj Kaur Chawla <amitoj1606@gmail.com> Applied, thanks. Takashi
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] ALSA: riptide: Use DIV_ROUND_UP Amitoj Kaur Chawla <amitoj1606@gmail.com> - 2016-06-29 17:00 +0200 Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP Takashi Sakamoto <o-takashi@sakamocchi.jp> - 2016-06-30 04:20 +0200 Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP Takashi Iwai <tiwai@suse.de> - 2016-06-30 08:40 +0200
csiph-web