Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1332248 > unrolled thread
| Started by | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| First post | 2016-02-11 18:20 +0100 |
| Last post | 2016-02-15 13:40 +0100 |
| Articles | 12 — 4 participants |
Back to article view | Back to linux.kernel
[PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-11 18:20 +0100
[PATCH 2/4] mailbox: mailbox-test: fix the compatible string Sudeep Holla <sudeep.holla@arm.com> - 2016-02-11 18:20 +0100
Re: [PATCH 2/4] mailbox: mailbox-test: fix the compatible string Lee Jones <lee.jones@linaro.org> - 2016-02-12 10:10 +0100
Re: [PATCH 2/4] mailbox: mailbox-test: fix the compatible string Rob Herring <robh@kernel.org> - 2016-02-12 17:50 +0100
[PATCH 1/4] mailbox: mailbox-test: rename driver as generic test driver Sudeep Holla <sudeep.holla@arm.com> - 2016-02-11 18:20 +0100
Re: [PATCH 1/4] mailbox: mailbox-test: rename driver as generic test driver Lee Jones <lee.jones@linaro.org> - 2016-02-12 10:10 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Lee Jones <lee.jones@linaro.org> - 2016-02-12 10:20 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-12 10:50 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-15 13:20 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-15 13:20 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Jassi Brar <jassisinghbrar@gmail.com> - 2016-02-15 13:40 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-15 13:40 +0100
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Date | 2016-02-11 18:20 +0100 |
| Subject | [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer |
| Message-ID | <r134l-3on-3@gated-at.bofh.it> |
Hi Lee, Jassi,
Assuming mailbox-test was designed to be generic, I am trying to extend
it to support single channel with separate Tx and Rx buffer. With these
changes I am able to test arm_mhu driver. However I couldn't understand
the intention of converting buffer to ASCII hex dump in read method.
I have a local change to remove that so that it can deal with any data
in any format(e.g. some protocol format) and userspace can deal with the
actual interpretation of the data. Let me know your thoughts on that.
Regards,
Sudeep
Sudeep Holla (4):
mailbox: mailbox-test: rename driver as generic test driver
mailbox: mailbox-test: fix the compatible string
mailbox: mailbox-test: use print_hex_dump_bytes to allow dynamic
printk
mailbox: mailbox-test: add support for separate tx/rx buffer with
single channel
.../devicetree/bindings/mailbox/sti-mailbox.txt | 2 +-
drivers/mailbox/mailbox-test.c | 50 ++++++++++++----------
2 files changed, 29 insertions(+), 23 deletions(-)
--
1.9.1
[toc] | [next] | [standalone]
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Date | 2016-02-11 18:20 +0100 |
| Subject | [PATCH 2/4] mailbox: mailbox-test: fix the compatible string |
| Message-ID | <r134m-3on-15@gated-at.bofh.it> |
| In reply to | #1332248 |
Underscores are usually forbidden in the compatible strings. So lets
remove it before the first users of this is seen.
Cc: Jassi Brar <jassisinghbrar@gmail.com>
Cc: Lee Jones <lee.jones@linaro.org>
Signed-off-by: Sudeep Holla <sudeep.holla@arm.com>
---
Documentation/devicetree/bindings/mailbox/sti-mailbox.txt | 2 +-
drivers/mailbox/mailbox-test.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt b/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
index b61eec920359..351f612673fc 100644
--- a/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
+++ b/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
@@ -44,7 +44,7 @@ Optional properties
Example:
mailbox_test {
- compatible = "mailbox_test";
+ compatible = "mailbox-test";
reg = <0x[shared_memory_address], [shared_memory_size]>;
mboxes = <&mailbox2 0 1>, <&mailbox0 2 1>;
mbox-names = "tx", "rx";
diff --git a/drivers/mailbox/mailbox-test.c b/drivers/mailbox/mailbox-test.c
index 3813f6d9eba9..036a852b5fa1 100644
--- a/drivers/mailbox/mailbox-test.c
+++ b/drivers/mailbox/mailbox-test.c
@@ -342,7 +342,7 @@ static int mbox_test_remove(struct platform_device *pdev)
}
static const struct of_device_id mbox_test_match[] = {
- { .compatible = "mailbox_test" },
+ { .compatible = "mailbox-test" },
{},
};
--
1.9.1
[toc] | [prev] | [next] | [standalone]
| From | Lee Jones <lee.jones@linaro.org> |
|---|---|
| Date | 2016-02-12 10:10 +0100 |
| Subject | Re: [PATCH 2/4] mailbox: mailbox-test: fix the compatible string |
| Message-ID | <r1hTJ-4Uy-27@gated-at.bofh.it> |
| In reply to | #1332249 |
On Thu, 11 Feb 2016, Sudeep Holla wrote:
> Underscores are usually forbidden in the compatible strings. So lets
> remove it before the first users of this is seen.
>
> Cc: Jassi Brar <jassisinghbrar@gmail.com>
> Cc: Lee Jones <lee.jones@linaro.org>
> Signed-off-by: Sudeep Holla <sudeep.holla@arm.com>
Acked-by: Lee Jones <lee.jones@linaro.org>
> ---
> Documentation/devicetree/bindings/mailbox/sti-mailbox.txt | 2 +-
> drivers/mailbox/mailbox-test.c | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt b/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
> index b61eec920359..351f612673fc 100644
> --- a/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
> +++ b/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
> @@ -44,7 +44,7 @@ Optional properties
> Example:
>
> mailbox_test {
> - compatible = "mailbox_test";
> + compatible = "mailbox-test";
> reg = <0x[shared_memory_address], [shared_memory_size]>;
> mboxes = <&mailbox2 0 1>, <&mailbox0 2 1>;
> mbox-names = "tx", "rx";
> diff --git a/drivers/mailbox/mailbox-test.c b/drivers/mailbox/mailbox-test.c
> index 3813f6d9eba9..036a852b5fa1 100644
> --- a/drivers/mailbox/mailbox-test.c
> +++ b/drivers/mailbox/mailbox-test.c
> @@ -342,7 +342,7 @@ static int mbox_test_remove(struct platform_device *pdev)
> }
>
> static const struct of_device_id mbox_test_match[] = {
> - { .compatible = "mailbox_test" },
> + { .compatible = "mailbox-test" },
> {},
> };
>
--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
[toc] | [prev] | [next] | [standalone]
| From | Rob Herring <robh@kernel.org> |
|---|---|
| Date | 2016-02-12 17:50 +0100 |
| Subject | Re: [PATCH 2/4] mailbox: mailbox-test: fix the compatible string |
| Message-ID | <r1p4R-14o-11@gated-at.bofh.it> |
| In reply to | #1332249 |
On Thu, Feb 11, 2016 at 05:13:26PM +0000, Sudeep Holla wrote: > Underscores are usually forbidden in the compatible strings. So lets > remove it before the first users of this is seen. > > Cc: Jassi Brar <jassisinghbrar@gmail.com> > Cc: Lee Jones <lee.jones@linaro.org> > Signed-off-by: Sudeep Holla <sudeep.holla@arm.com> > --- > Documentation/devicetree/bindings/mailbox/sti-mailbox.txt | 2 +- > drivers/mailbox/mailbox-test.c | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) Acked-by: Rob Herring <robh@kernel.org>
[toc] | [prev] | [next] | [standalone]
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Date | 2016-02-11 18:20 +0100 |
| Subject | [PATCH 1/4] mailbox: mailbox-test: rename driver as generic test driver |
| Message-ID | <r134m-3on-25@gated-at.bofh.it> |
| In reply to | #1332248 |
This mailbox-test driver was designed to be generic, so let's remove ST
tag on it and make it generic.
Cc: Jassi Brar <jassisinghbrar@gmail.com>
Cc: Lee Jones <lee.jones@linaro.org>
Signed-off-by: Sudeep Holla <sudeep.holla@arm.com>
---
drivers/mailbox/mailbox-test.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/mailbox/mailbox-test.c b/drivers/mailbox/mailbox-test.c
index 684ae17dcf39..3813f6d9eba9 100644
--- a/drivers/mailbox/mailbox-test.c
+++ b/drivers/mailbox/mailbox-test.c
@@ -348,7 +348,7 @@ static const struct of_device_id mbox_test_match[] = {
static struct platform_driver mbox_test_driver = {
.driver = {
- .name = "mailbox_sti_test",
+ .name = "mailbox_test",
.of_match_table = mbox_test_match,
},
.probe = mbox_test_probe,
--
1.9.1
[toc] | [prev] | [next] | [standalone]
| From | Lee Jones <lee.jones@linaro.org> |
|---|---|
| Date | 2016-02-12 10:10 +0100 |
| Subject | Re: [PATCH 1/4] mailbox: mailbox-test: rename driver as generic test driver |
| Message-ID | <r1hTI-4Uy-7@gated-at.bofh.it> |
| In reply to | #1332253 |
On Thu, 11 Feb 2016, Sudeep Holla wrote:
> This mailbox-test driver was designed to be generic, so let's remove ST
> tag on it and make it generic.
>
> Cc: Jassi Brar <jassisinghbrar@gmail.com>
> Cc: Lee Jones <lee.jones@linaro.org>
> Signed-off-by: Sudeep Holla <sudeep.holla@arm.com>
> ---
> drivers/mailbox/mailbox-test.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
Acked-by: Lee Jones <lee.jones@linaro.org>
> diff --git a/drivers/mailbox/mailbox-test.c b/drivers/mailbox/mailbox-test.c
> index 684ae17dcf39..3813f6d9eba9 100644
> --- a/drivers/mailbox/mailbox-test.c
> +++ b/drivers/mailbox/mailbox-test.c
> @@ -348,7 +348,7 @@ static const struct of_device_id mbox_test_match[] = {
>
> static struct platform_driver mbox_test_driver = {
> .driver = {
> - .name = "mailbox_sti_test",
> + .name = "mailbox_test",
> .of_match_table = mbox_test_match,
> },
> .probe = mbox_test_probe,
--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
[toc] | [prev] | [next] | [standalone]
| From | Lee Jones <lee.jones@linaro.org> |
|---|---|
| Date | 2016-02-12 10:20 +0100 |
| Subject | Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer |
| Message-ID | <r1i3p-4XY-29@gated-at.bofh.it> |
| In reply to | #1332248 |
On Thu, 11 Feb 2016, Sudeep Holla wrote: > Hi Lee, Jassi, > > Assuming mailbox-test was designed to be generic, I am trying to extend > it to support single channel with separate Tx and Rx buffer. With these > changes I am able to test arm_mhu driver. However I couldn't understand > the intention of converting buffer to ASCII hex dump in read method. > I have a local change to remove that so that it can deal with any data > in any format(e.g. some protocol format) Not sure quite what you mean. Hexdump can handle any data? If the hex value read isn't an ASCII value, a '.' is printed on the right hand side. What data are you expecting that you can't analyse with hexdump? > and userspace can deal with the > actual interpretation of the data. Let me know your thoughts on that. > > Regards, > Sudeep > > Sudeep Holla (4): > mailbox: mailbox-test: rename driver as generic test driver > mailbox: mailbox-test: fix the compatible string > mailbox: mailbox-test: use print_hex_dump_bytes to allow dynamic > printk > mailbox: mailbox-test: add support for separate tx/rx buffer with > single channel > > .../devicetree/bindings/mailbox/sti-mailbox.txt | 2 +- > drivers/mailbox/mailbox-test.c | 50 ++++++++++++---------- > 2 files changed, 29 insertions(+), 23 deletions(-) > -- Lee Jones Linaro STMicroelectronics Landing Team Lead Linaro.org │ Open source software for ARM SoCs Follow Linaro: Facebook | Twitter | Blog
[toc] | [prev] | [next] | [standalone]
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Date | 2016-02-12 10:50 +0100 |
| Subject | Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer |
| Message-ID | <r1iwr-584-43@gated-at.bofh.it> |
| In reply to | #1332605 |
On 12/02/16 09:17, Lee Jones wrote:
> On Thu, 11 Feb 2016, Sudeep Holla wrote:
>
>> Hi Lee, Jassi,
>>
>> Assuming mailbox-test was designed to be generic, I am trying to extend
>> it to support single channel with separate Tx and Rx buffer. With these
>> changes I am able to test arm_mhu driver. However I couldn't understand
>> the intention of converting buffer to ASCII hex dump in read method.
>> I have a local change to remove that so that it can deal with any data
>> in any format(e.g. some protocol format)
>
> Not sure quite what you mean. Hexdump can handle any data? If the
> hex value read isn't an ASCII value, a '.' is printed on the right
> hand side. What data are you expecting that you can't analyse with
> hexdump?
>
Sorry for not being clear. Hexdump can handle any data. I do see that
it displays quite nicely at the driver level which is nice.
However my question was why is the the buffer copied to user space is
not the original raw data, rather it's ASCII converted which is good for
nice logging.
One of the use-case the testing guys wants is the check the protocol
specification using this. In their case they expect the test driver to
send the raw data as is from the driver rather than the converted ASCII
buffer. I tend to agree with them for 2 reasons:
1. userspace can do the conversion if required
2. the input buffer is not converted(i.e. in the write path), so it's
bit of inconsistent there.
--
Regards,
Sudeep
[toc] | [prev] | [next] | [standalone]
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Date | 2016-02-15 13:20 +0100 |
| Subject | Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer |
| Message-ID | <r2qie-Lf-17@gated-at.bofh.it> |
| In reply to | #1332640 |
Hi Lee, On 12/02/16 09:41, Sudeep Holla wrote: > > > On 12/02/16 09:17, Lee Jones wrote: >> On Thu, 11 Feb 2016, Sudeep Holla wrote: >> >>> Hi Lee, Jassi, >>> >>> Assuming mailbox-test was designed to be generic, I am trying to extend >>> it to support single channel with separate Tx and Rx buffer. With these >>> changes I am able to test arm_mhu driver. However I couldn't understand >>> the intention of converting buffer to ASCII hex dump in read method. >>> I have a local change to remove that so that it can deal with any data >>> in any format(e.g. some protocol format) >> >> Not sure quite what you mean. Hexdump can handle any data? If the >> hex value read isn't an ASCII value, a '.' is printed on the right >> hand side. What data are you expecting that you can't analyse with >> hexdump? >> > > Sorry for not being clear. Hexdump can handle any data. I do see that > it displays quite nicely at the driver level which is nice. > > However my question was why is the the buffer copied to user space is > not the original raw data, rather it's ASCII converted which is good for > nice logging. > > One of the use-case the testing guys wants is the check the protocol > specification using this. In their case they expect the test driver to > send the raw data as is from the driver rather than the converted ASCII > buffer. I tend to agree with them for 2 reasons: > > 1. userspace can do the conversion if required > 2. the input buffer is not converted(i.e. in the write path), so it's > bit of inconsistent there. > Thoughts on this or am I still not clear ? -- Regards, Sudeep
[toc] | [prev] | [next] | [standalone]
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Date | 2016-02-15 13:20 +0100 |
| Subject | Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer |
| Message-ID | <r2qie-Lf-7@gated-at.bofh.it> |
| In reply to | #1332248 |
Hi Jassi, On 11/02/16 17:13, Sudeep Holla wrote: > Hi Lee, Jassi, > > Assuming mailbox-test was designed to be generic, I am trying to extend > it to support single channel with separate Tx and Rx buffer. With these > changes I am able to test arm_mhu driver. However I couldn't understand > the intention of converting buffer to ASCII hex dump in read method. > I have a local change to remove that so that it can deal with any data > in any format(e.g. some protocol format) and userspace can deal with the > actual interpretation of the data. Let me know your thoughts on that. > Can you review this ? It would be good to get this in for v4.6 -- Regards, Sudeep
[toc] | [prev] | [next] | [standalone]
| From | Jassi Brar <jassisinghbrar@gmail.com> |
|---|---|
| Date | 2016-02-15 13:40 +0100 |
| Subject | Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer |
| Message-ID | <r2qBB-Um-27@gated-at.bofh.it> |
| In reply to | #1334428 |
On Mon, Feb 15, 2016 at 5:47 PM, Sudeep Holla <sudeep.holla@arm.com> wrote: > Hi Jassi, > > On 11/02/16 17:13, Sudeep Holla wrote: >> >> Hi Lee, Jassi, >> >> Assuming mailbox-test was designed to be generic, I am trying to extend >> it to support single channel with separate Tx and Rx buffer. With these >> changes I am able to test arm_mhu driver. However I couldn't understand >> the intention of converting buffer to ASCII hex dump in read method. >> I have a local change to remove that so that it can deal with any data >> in any format(e.g. some protocol format) and userspace can deal with the >> actual interpretation of the data. Let me know your thoughts on that. >> > > Can you review this ? It would be good to get this in for v4.6 > Seems simple enough. So once you and Lee are in sync...
[toc] | [prev] | [next] | [standalone]
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Date | 2016-02-15 13:40 +0100 |
| Subject | Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer |
| Message-ID | <r2qBB-Um-31@gated-at.bofh.it> |
| In reply to | #1334436 |
On 15/02/16 12:31, Jassi Brar wrote: > On Mon, Feb 15, 2016 at 5:47 PM, Sudeep Holla <sudeep.holla@arm.com> wrote: >> Hi Jassi, >> >> On 11/02/16 17:13, Sudeep Holla wrote: >>> >>> Hi Lee, Jassi, >>> >>> Assuming mailbox-test was designed to be generic, I am trying to extend >>> it to support single channel with separate Tx and Rx buffer. With these >>> changes I am able to test arm_mhu driver. However I couldn't understand >>> the intention of converting buffer to ASCII hex dump in read method. >>> I have a local change to remove that so that it can deal with any data >>> in any format(e.g. some protocol format) and userspace can deal with the >>> actual interpretation of the data. Let me know your thoughts on that. >>> >> >> Can you review this ? It would be good to get this in for v4.6 >> > Seems simple enough. So once you and Lee are in sync... > That was quick :). Anyways IIUC Lee agrees with most of the changes. The question I am asking is not part of this series, I didn't make the change to remove hexdump yet, I am trying to understand the reasoning for doing that and also explaining my requirement as why I want to remove it. -- Regards, Sudeep
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web