Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1332248
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer |
| Date | 2016-02-11 18:20 +0100 |
| Message-ID | <r134l-3on-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Hi Lee, Jassi,
Assuming mailbox-test was designed to be generic, I am trying to extend
it to support single channel with separate Tx and Rx buffer. With these
changes I am able to test arm_mhu driver. However I couldn't understand
the intention of converting buffer to ASCII hex dump in read method.
I have a local change to remove that so that it can deal with any data
in any format(e.g. some protocol format) and userspace can deal with the
actual interpretation of the data. Let me know your thoughts on that.
Regards,
Sudeep
Sudeep Holla (4):
mailbox: mailbox-test: rename driver as generic test driver
mailbox: mailbox-test: fix the compatible string
mailbox: mailbox-test: use print_hex_dump_bytes to allow dynamic
printk
mailbox: mailbox-test: add support for separate tx/rx buffer with
single channel
.../devicetree/bindings/mailbox/sti-mailbox.txt | 2 +-
drivers/mailbox/mailbox-test.c | 50 ++++++++++++----------
2 files changed, 29 insertions(+), 23 deletions(-)
--
1.9.1
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-11 18:20 +0100
[PATCH 2/4] mailbox: mailbox-test: fix the compatible string Sudeep Holla <sudeep.holla@arm.com> - 2016-02-11 18:20 +0100
Re: [PATCH 2/4] mailbox: mailbox-test: fix the compatible string Lee Jones <lee.jones@linaro.org> - 2016-02-12 10:10 +0100
Re: [PATCH 2/4] mailbox: mailbox-test: fix the compatible string Rob Herring <robh@kernel.org> - 2016-02-12 17:50 +0100
[PATCH 1/4] mailbox: mailbox-test: rename driver as generic test driver Sudeep Holla <sudeep.holla@arm.com> - 2016-02-11 18:20 +0100
Re: [PATCH 1/4] mailbox: mailbox-test: rename driver as generic test driver Lee Jones <lee.jones@linaro.org> - 2016-02-12 10:10 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Lee Jones <lee.jones@linaro.org> - 2016-02-12 10:20 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-12 10:50 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-15 13:20 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-15 13:20 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Jassi Brar <jassisinghbrar@gmail.com> - 2016-02-15 13:40 +0100
Re: [PATCH 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-15 13:40 +0100
csiph-web