Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1239208 > unrolled thread
| Started by | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| First post | 2015-10-04 22:40 +0200 |
| Last post | 2015-10-04 23:10 +0200 |
| Articles | 11 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 22:40 +0200
[PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
[PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
[PATCH 1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
[PATCH 5/8] dwc3-pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
[PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Greg KH <gregkh@linuxfoundation.org> - 2015-10-05 05:20 +0200
Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-05 15:20 +0200
[PATCH 6/8] amd5536udc: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
[PATCH 4/8] dwc2: pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
[PATCH 7/8] pch_udc: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 22:40 +0200 |
| Subject | [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYeC-2GC-9@gated-at.bofh.it> |
Hello. Here's a set of 8 patches against the 'usb-next' branch of Greg KH's 'usb.git' repo. It's to eliminate the use of the PCI_DEVICE() macro where less verbose PCI_VDEVICE() should have been used. [1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE() [2/8] ohci-pci:-use-PCI_VDEVICE() instead of PCI_DEVICE() [3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() [4/8] dwc2: pci: use PCI_VDEVICE() instead of PCI_DEVICE() [5/8] dwc3-pci: use PCI_VDEVICE() instead of PCI_DEVICE() [6/8] amd5536udc: use PCI_VDEVICE() instead of PCI_DEVICE() [7/8] pch_udc: use PCI_VDEVICE() instead of PCI_DEVICE() [8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() WBR, Sergei -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 23:00 +0200 |
| Subject | [PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYxX-33f-3@gated-at.bofh.it> |
| In reply to | #1239208 |
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
---
drivers/usb/chipidea/ci_hdrc_pci.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Index: usb/drivers/usb/chipidea/ci_hdrc_pci.c
===================================================================
--- usb.orig/drivers/usb/chipidea/ci_hdrc_pci.c
+++ usb/drivers/usb/chipidea/ci_hdrc_pci.c
@@ -142,16 +142,16 @@ static const struct pci_device_id ci_hdr
.driver_data = (kernel_ulong_t)&pci_platdata,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0x0811),
+ PCI_VDEVICE(INTEL, 0x0811),
.driver_data = (kernel_ulong_t)&langwell_pci_platdata,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0x0829),
+ PCI_VDEVICE(INTEL, 0x0829),
.driver_data = (kernel_ulong_t)&penwell_pci_platdata,
},
{
/* Intel Clovertrail */
- PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0xe006),
+ PCI_VDEVICE(INTEL, 0xe006),
.driver_data = (kernel_ulong_t)&penwell_pci_platdata,
},
{ 0 } /* end: all zeroes */
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 23:00 +0200 |
| Subject | [PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYxX-33f-9@gated-at.bofh.it> |
| In reply to | #1239208 |
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
---
drivers/usb/host/ohci-pci.c | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
Index: usb/drivers/usb/host/ohci-pci.c
===================================================================
--- usb.orig/drivers/usb/host/ohci-pci.c
+++ usb/drivers/usb/host/ohci-pci.c
@@ -167,27 +167,27 @@ static int ohci_quirk_amd700(struct usb_
/* List of quirks for OHCI */
static const struct pci_device_id ohci_pci_quirks[] = {
{
- PCI_DEVICE(PCI_VENDOR_ID_AMD, 0x740c),
+ PCI_VDEVICE(AMD, 0x740c),
.driver_data = (unsigned long)ohci_quirk_amd756,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_OPTI, 0xc861),
+ PCI_VDEVICE(OPTI, 0xc861),
.driver_data = (unsigned long)ohci_quirk_opti,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_NS, PCI_ANY_ID),
+ PCI_VDEVICE(NS, PCI_ANY_ID),
.driver_data = (unsigned long)ohci_quirk_ns,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_COMPAQ, 0xa0f8),
+ PCI_VDEVICE(COMPAQ, 0xa0f8),
.driver_data = (unsigned long)ohci_quirk_zfmicro,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_TOSHIBA_2, 0x01b6),
+ PCI_VDEVICE(TOSHIBA_2, 0x01b6),
.driver_data = (unsigned long)ohci_quirk_toshiba_scc,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_NEC, PCI_DEVICE_ID_NEC_USB),
+ PCI_VDEVICE(NEC, PCI_DEVICE_ID_NEC_USB),
.driver_data = (unsigned long)ohci_quirk_nec,
},
{
@@ -199,19 +199,19 @@ static const struct pci_device_id ohci_p
.driver_data = (unsigned long) broken_suspend,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_ITE, 0x8152),
+ PCI_VDEVICE(ITE, 0x8152),
.driver_data = (unsigned long) broken_suspend,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_ATI, 0x4397),
+ PCI_VDEVICE(ATI, 0x4397),
.driver_data = (unsigned long)ohci_quirk_amd700,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_ATI, 0x4398),
+ PCI_VDEVICE(ATI, 0x4398),
.driver_data = (unsigned long)ohci_quirk_amd700,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_ATI, 0x4399),
+ PCI_VDEVICE(ATI, 0x4399),
.driver_data = (unsigned long)ohci_quirk_amd700,
},
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 23:00 +0200 |
| Subject | [PATCH 1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYxX-33f-11@gated-at.bofh.it> |
| In reply to | #1239208 |
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
---
drivers/usb/host/ehci-pci.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Index: usb/drivers/usb/host/ehci-pci.c
===================================================================
--- usb.orig/drivers/usb/host/ehci-pci.c
+++ usb/drivers/usb/host/ehci-pci.c
@@ -49,9 +49,9 @@ static inline bool is_intel_quark_x1000(
*/
static const struct pci_device_id bypass_pci_id_table[] = {
/* ChipIdea on Intel MID platform */
- { PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0x0811), },
- { PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0x0829), },
- { PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0xe006), },
+ { PCI_VDEVICE(INTEL, 0x0811), },
+ { PCI_VDEVICE(INTEL, 0x0829), },
+ { PCI_VDEVICE(INTEL, 0xe006), },
{}
};
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 23:10 +0200 |
| Subject | [PATCH 5/8] dwc3-pci: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYHD-3u3-1@gated-at.bofh.it> |
| In reply to | #1239208 |
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
---
drivers/usb/dwc3/dwc3-pci.c | 17 +++++++----------
1 file changed, 7 insertions(+), 10 deletions(-)
Index: usb/drivers/usb/dwc3/dwc3-pci.c
===================================================================
--- usb.orig/drivers/usb/dwc3/dwc3-pci.c
+++ usb/drivers/usb/dwc3/dwc3-pci.c
@@ -174,16 +174,13 @@ static void dwc3_pci_remove(struct pci_d
}
static const struct pci_device_id dwc3_pci_id_table[] = {
- {
- PCI_DEVICE(PCI_VENDOR_ID_SYNOPSYS,
- PCI_DEVICE_ID_SYNOPSYS_HAPSUSB3),
- },
- { PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_BSW), },
- { PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_BYT), },
- { PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_MRFLD), },
- { PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_SPTLP), },
- { PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_SPTH), },
- { PCI_DEVICE(PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_NL_USB), },
+ { PCI_VDEVICE(SYNOPSYS, PCI_DEVICE_ID_SYNOPSYS_HAPSUSB3), },
+ { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_BSW), },
+ { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_BYT), },
+ { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_MRFLD), },
+ { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_SPTLP), },
+ { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_SPTH), },
+ { PCI_VDEVICE(AMD, PCI_DEVICE_ID_AMD_NL_USB), },
{ } /* Terminating Entry */
};
MODULE_DEVICE_TABLE(pci, dwc3_pci_id_table);
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 23:10 +0200 |
| Subject | [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYHD-3u3-9@gated-at.bofh.it> |
| In reply to | #1239208 |
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
---
drivers/usb/gadget/udc/bdc/bdc_pci.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: usb/drivers/usb/gadget/udc/bdc/bdc_pci.c
===================================================================
--- usb.orig/drivers/usb/gadget/udc/bdc/bdc_pci.c
+++ usb/drivers/usb/gadget/udc/bdc/bdc_pci.c
@@ -113,7 +113,7 @@ static void bdc_pci_remove(struct pci_de
}
static struct pci_device_id bdc_pci_id_table[] = {
- { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, BDC_PCI_PID), },
+ { PCI_VDEVICE(BROADCOM, BDC_PCI_PID), },
{} /* Terminating Entry */
};
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Greg KH <gregkh@linuxfoundation.org> |
|---|---|
| Date | 2015-10-05 05:20 +0200 |
| Subject | Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qg4tH-3lu-5@gated-at.bofh.it> |
| In reply to | #1239221 |
On Mon, Oct 05, 2015 at 12:08:26AM +0300, Sergei Shtylyov wrote: > Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Why? I hate PCI_VDEVICE(), it's impossible to grep for things and does not help with readability and is pointless. My one wish was that when I was the PCI maintainer I would have just deleted the thing from the kernel entirely instead of leaving it there hoping no one would use it. I don't like these types of pointless patches, sorry. thanks, greg k-h -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-05 15:20 +0200 |
| Subject | Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qgdQm-8oB-5@gated-at.bofh.it> |
| In reply to | #1239265 |
Hello.
On 10/5/2015 6:16 AM, Greg KH wrote:
>> Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
> Why?
Seemed a good idea to me back in March. :-)
> I hate PCI_VDEVICE(), it's impossible to grep for things and does
Didn't think about grepping...
> not help with readability and is pointless. My one wish was that when I
> was the PCI maintainer I would have just deleted the thing from the
> kernel entirely instead of leaving it there hoping no one would use it.
Thanks for the idea. :-)
> I don't like these types of pointless patches, sorry.
I hope you don't have the same strong feelings about PCI_DEVICE_SUB().
There's one place (in ohci-pci.c IIRC) it can be used...
> thanks,
>
> greg k-h
MBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 23:10 +0200 |
| Subject | [PATCH 6/8] amd5536udc: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYHE-3u3-21@gated-at.bofh.it> |
| In reply to | #1239208 |
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
---
drivers/usb/gadget/udc/amd5536udc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: usb/drivers/usb/gadget/udc/amd5536udc.c
===================================================================
--- usb.orig/drivers/usb/gadget/udc/amd5536udc.c
+++ usb/drivers/usb/gadget/udc/amd5536udc.c
@@ -3405,7 +3405,7 @@ static int udc_remote_wakeup(struct udc
/* PCI device parameters */
static const struct pci_device_id pci_id[] = {
{
- PCI_DEVICE(PCI_VENDOR_ID_AMD, 0x2096),
+ PCI_VDEVICE(AMD, 0x2096),
.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
.class_mask = 0xffffffff,
},
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 23:10 +0200 |
| Subject | [PATCH 4/8] dwc2: pci: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYHE-3u3-25@gated-at.bofh.it> |
| In reply to | #1239208 |
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
---
drivers/usb/dwc2/pci.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
Index: usb/drivers/usb/dwc2/pci.c
===================================================================
--- usb.orig/drivers/usb/dwc2/pci.c
+++ usb/drivers/usb/dwc2/pci.c
@@ -145,11 +145,10 @@ err:
static const struct pci_device_id dwc2_pci_ids[] = {
{
- PCI_DEVICE(PCI_VENDOR_ID_SYNOPSYS, PCI_PRODUCT_ID_HAPS_HSOTG),
+ PCI_VDEVICE(SYNOPSYS, PCI_PRODUCT_ID_HAPS_HSOTG),
},
{
- PCI_DEVICE(PCI_VENDOR_ID_STMICRO,
- PCI_DEVICE_ID_STMICRO_USB_OTG),
+ PCI_VDEVICE(STMICRO, PCI_DEVICE_ID_STMICRO_USB_OTG),
},
{ /* end: all zeroes */ }
};
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Date | 2015-10-04 23:10 +0200 |
| Subject | [PATCH 7/8] pch_udc: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Message-ID | <qfYHE-3u3-29@gated-at.bofh.it> |
| In reply to | #1239208 |
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
---
drivers/usb/gadget/udc/pch_udc.c | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)
Index: usb/drivers/usb/gadget/udc/pch_udc.c
===================================================================
--- usb.orig/drivers/usb/gadget/udc/pch_udc.c
+++ usb/drivers/usb/gadget/udc/pch_udc.c
@@ -3232,23 +3232,22 @@ finished:
static const struct pci_device_id pch_udc_pcidev_id[] = {
{
- PCI_DEVICE(PCI_VENDOR_ID_INTEL,
- PCI_DEVICE_ID_INTEL_QUARK_X1000_UDC),
+ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_QUARK_X1000_UDC),
.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
.class_mask = 0xffffffff,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_EG20T_UDC),
+ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_EG20T_UDC),
.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
.class_mask = 0xffffffff,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_ROHM, PCI_DEVICE_ID_ML7213_IOH_UDC),
+ PCI_VDEVICE(ROHM, PCI_DEVICE_ID_ML7213_IOH_UDC),
.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
.class_mask = 0xffffffff,
},
{
- PCI_DEVICE(PCI_VENDOR_ID_ROHM, PCI_DEVICE_ID_ML7831_IOH_UDC),
+ PCI_VDEVICE(ROHM, PCI_DEVICE_ID_ML7831_IOH_UDC),
.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
.class_mask = 0xffffffff,
},
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web