Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1239265

Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()

From Greg KH <gregkh@linuxfoundation.org>
Newsgroups linux.kernel
Subject Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()
Date 2015-10-05 05:20 +0200
Message-ID <qg4tH-3lu-5@gated-at.bofh.it> (permalink)
References <qfYeC-2GC-9@gated-at.bofh.it> <qfYHD-3u3-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Oct 05, 2015 at 12:08:26AM +0300, Sergei Shtylyov wrote:
> Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Why?  I hate PCI_VDEVICE(), it's impossible to grep for things and does
not help with readability and is pointless.  My one wish was that when I
was the PCI maintainer I would have just deleted the thing from the
kernel entirely instead of leaving it there hoping no one would use it.

I don't like these types of pointless patches, sorry.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 22:40 +0200
  [PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
  [PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
  [PATCH 1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
  [PATCH 5/8] dwc3-pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
  [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
    Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Greg KH <gregkh@linuxfoundation.org> - 2015-10-05 05:20 +0200
      Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-05 15:20 +0200
  [PATCH 6/8] amd5536udc: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
  [PATCH 4/8] dwc2: pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
  [PATCH 7/8] pch_udc: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200

csiph-web