Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1239541
| From | Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() |
| Date | 2015-10-05 15:20 +0200 |
| Message-ID | <qgdQm-8oB-5@gated-at.bofh.it> (permalink) |
| References | <qfYeC-2GC-9@gated-at.bofh.it> <qfYHD-3u3-9@gated-at.bofh.it> <qg4tH-3lu-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hello.
On 10/5/2015 6:16 AM, Greg KH wrote:
>> Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
> Why?
Seemed a good idea to me back in March. :-)
> I hate PCI_VDEVICE(), it's impossible to grep for things and does
Didn't think about grepping...
> not help with readability and is pointless. My one wish was that when I
> was the PCI maintainer I would have just deleted the thing from the
> kernel entirely instead of leaving it there hoping no one would use it.
Thanks for the idea. :-)
> I don't like these types of pointless patches, sorry.
I hope you don't have the same strong feelings about PCI_DEVICE_SUB().
There's one place (in ohci-pci.c IIRC) it can be used...
> thanks,
>
> greg k-h
MBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 22:40 +0200
[PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
[PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
[PATCH 1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:00 +0200
[PATCH 5/8] dwc3-pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
[PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Greg KH <gregkh@linuxfoundation.org> - 2015-10-05 05:20 +0200
Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-05 15:20 +0200
[PATCH 6/8] amd5536udc: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
[PATCH 4/8] dwc2: pci: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
[PATCH 7/8] pch_udc: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-04 23:10 +0200
csiph-web