Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1168603 > unrolled thread
| Started by | Charles Keepax <ckeepax@opensource.wolfsonmicro.com> |
|---|---|
| First post | 2015-06-19 10:20 +0200 |
| Last post | 2015-06-19 11:10 +0200 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings Charles Keepax <ckeepax@opensource.wolfsonmicro.com> - 2015-06-19 10:20 +0200
Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings Chanwoo Choi <cwchoi00@gmail.com> - 2015-06-19 10:30 +0200
Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings Charles Keepax <ckeepax@opensource.wolfsonmicro.com> - 2015-06-19 11:10 +0200
| From | Charles Keepax <ckeepax@opensource.wolfsonmicro.com> |
|---|---|
| Date | 2015-06-19 10:20 +0200 |
| Subject | Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings |
| Message-ID | <pCZGN-1Jh-11@gated-at.bofh.it> |
On Fri, Jun 19, 2015 at 11:25:57AM +0900, Chanwoo Choi wrote:
> Hi Charles,
>
> On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax
> <ckeepax@opensource.wolfsonmicro.com> wrote:
> > This patch adds bindings for the basic microphone detection platform
> > data.
> >
> > Signed-off-by: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
> > ---
> > + dbtime = 0;
> > + device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime);
> > + switch (dbtime) {
> > + case 2:
>
> I'd like you to define the constant variable for specific integer
> value to improve the readability.
> e.g.,
>
> #define MICD_DBTIME_XXX 2
> #define MICD_DBTIME_XXX 4
>
> > + pdata->micd_dbtime = 0x10000;
>
> Also, you better to define the constant variable for "0x10000" to
> improbe readability in the include/linux/mfd/arizona.h. If you just
> use the hex value, the other developer cannot analyze the meaning of
> "0x10000".
>
> > + break;
> > + case 4:
>
> ditto.
>
I am not sure these two really warrant a define the number in DT
indicates the number of debounces to perform.
#define MICD_DBTIME_TWO 2
switch (dbtime)
case MICD_DBTIME_TWO:
Is if anything less clear than just using 2 directly. I could
perhaps rename the varible to num_debounces instead?
Thanks,
Charles
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Chanwoo Choi <cwchoi00@gmail.com> |
|---|---|
| Date | 2015-06-19 10:30 +0200 |
| Message-ID | <pCZQu-1Uu-17@gated-at.bofh.it> |
| In reply to | #1168603 |
On Fri, Jun 19, 2015 at 5:17 PM, Charles Keepax
<ckeepax@opensource.wolfsonmicro.com> wrote:
> On Fri, Jun 19, 2015 at 11:25:57AM +0900, Chanwoo Choi wrote:
>> Hi Charles,
>>
>> On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax
>> <ckeepax@opensource.wolfsonmicro.com> wrote:
>> > This patch adds bindings for the basic microphone detection platform
>> > data.
>> >
>> > Signed-off-by: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
>> > ---
>> > + dbtime = 0;
>> > + device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime);
>> > + switch (dbtime) {
>> > + case 2:
>>
>> I'd like you to define the constant variable for specific integer
>> value to improve the readability.
>> e.g.,
>>
>> #define MICD_DBTIME_XXX 2
>> #define MICD_DBTIME_XXX 4
>>
>> > + pdata->micd_dbtime = 0x10000;
>>
>> Also, you better to define the constant variable for "0x10000" to
>> improbe readability in the include/linux/mfd/arizona.h. If you just
>> use the hex value, the other developer cannot analyze the meaning of
>> "0x10000".
>>
>> > + break;
>> > + case 4:
>>
>> ditto.
>>
>
> I am not sure these two really warrant a define the number in DT
> indicates the number of debounces to perform.
>
> #define MICD_DBTIME_TWO 2
No. I mean that you should define the appropriate name of definition
to indicate the meaning of 2 or 4. Just not 2 -> TWO.
2 is 2 second? or 2 is milli-second? or Is there any other meaning?
I can never know the meaning of '2' without any description and any
proper name of definition.
Thanks,
Chanwoo CHOi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Charles Keepax <ckeepax@opensource.wolfsonmicro.com> |
|---|---|
| Date | 2015-06-19 11:10 +0200 |
| Message-ID | <pD0tc-2Tl-9@gated-at.bofh.it> |
| In reply to | #1168608 |
On Fri, Jun 19, 2015 at 05:28:11PM +0900, Chanwoo Choi wrote:
> On Fri, Jun 19, 2015 at 5:17 PM, Charles Keepax
> <ckeepax@opensource.wolfsonmicro.com> wrote:
> > On Fri, Jun 19, 2015 at 11:25:57AM +0900, Chanwoo Choi wrote:
> >> Hi Charles,
> >>
> >> On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax
> >> <ckeepax@opensource.wolfsonmicro.com> wrote:
> >> > This patch adds bindings for the basic microphone detection platform
> >> > data.
> >> >
> >> > Signed-off-by: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
> >> > ---
> >> > + dbtime = 0;
> >> > + device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime);
> >> > + switch (dbtime) {
> >> > + case 2:
> >>
> >> I'd like you to define the constant variable for specific integer
> >> value to improve the readability.
> >> e.g.,
> >>
> >> #define MICD_DBTIME_XXX 2
> >> #define MICD_DBTIME_XXX 4
> >>
> >> > + pdata->micd_dbtime = 0x10000;
> >>
> >> Also, you better to define the constant variable for "0x10000" to
> >> improbe readability in the include/linux/mfd/arizona.h. If you just
> >> use the hex value, the other developer cannot analyze the meaning of
> >> "0x10000".
> >>
> >> > + break;
> >> > + case 4:
> >>
> >> ditto.
> >>
> >
> > I am not sure these two really warrant a define the number in DT
> > indicates the number of debounces to perform.
> >
> > #define MICD_DBTIME_TWO 2
>
> No. I mean that you should define the appropriate name of definition
> to indicate the meaning of 2 or 4. Just not 2 -> TWO.
>
> 2 is 2 second? or 2 is milli-second? or Is there any other meaning?
> I can never know the meaning of '2' without any description and any
> proper name of definition.
It is literally two, two debounces, I really can't see what I
could call the define. What do you think to the idea I suggested
to rename the variable dbtime -> num_debounces?
Thanks,
Charles
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web