Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1168645

Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings

From Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings
Date 2015-06-19 11:10 +0200
Message-ID <pD0tc-2Tl-9@gated-at.bofh.it> (permalink)
References <pCJsm-3cl-3@gated-at.bofh.it> <pCJsm-3cl-1@gated-at.bofh.it> <pCUe6-2c9-9@gated-at.bofh.it> <pCZGN-1Jh-11@gated-at.bofh.it> <pCZQu-1Uu-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Jun 19, 2015 at 05:28:11PM +0900, Chanwoo Choi wrote:
> On Fri, Jun 19, 2015 at 5:17 PM, Charles Keepax
> <ckeepax@opensource.wolfsonmicro.com> wrote:
> > On Fri, Jun 19, 2015 at 11:25:57AM +0900, Chanwoo Choi wrote:
> >> Hi Charles,
> >>
> >> On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax
> >> <ckeepax@opensource.wolfsonmicro.com> wrote:
> >> > This patch adds bindings for the basic microphone detection platform
> >> > data.
> >> >
> >> > Signed-off-by: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
> >> > ---
> >> > +       dbtime = 0;
> >> > +       device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime);
> >> > +       switch (dbtime) {
> >> > +       case 2:
> >>
> >> I'd like you to define the constant variable for specific integer
> >> value to improve the readability.
> >> e.g.,
> >>
> >> #define MICD_DBTIME_XXX 2
> >> #define MICD_DBTIME_XXX 4
> >>
> >> > +               pdata->micd_dbtime = 0x10000;
> >>
> >> Also, you better to define the constant variable for "0x10000" to
> >> improbe readability in the include/linux/mfd/arizona.h. If you just
> >> use the hex value, the other developer cannot analyze the meaning of
> >> "0x10000".
> >>
> >> > +               break;
> >> > +       case 4:
> >>
> >> ditto.
> >>
> >
> > I am not sure these two really warrant a define the number in DT
> > indicates the number of debounces to perform.
> >
> > #define MICD_DBTIME_TWO 2
> 
> No. I mean that you should define the appropriate name of definition
> to indicate the meaning of 2 or 4. Just not 2 -> TWO.
> 
> 2 is 2 second? or 2 is milli-second? or Is there any other meaning?
> I can never know the meaning of '2' without any description and any
> proper name of definition.

It is literally two, two debounces, I really can't see what I
could call the define. What do you think to the idea I suggested
to rename the variable dbtime -> num_debounces?

Thanks,
Charles
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection  DT/ACPI bindings Charles Keepax <ckeepax@opensource.wolfsonmicro.com> - 2015-06-19 10:20 +0200
  Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection  DT/ACPI bindings Chanwoo Choi <cwchoi00@gmail.com> - 2015-06-19 10:30 +0200
    Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection  DT/ACPI bindings Charles Keepax <ckeepax@opensource.wolfsonmicro.com> - 2015-06-19 11:10 +0200

csiph-web