Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1742304

Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port

Path csiph.com!news.mixmin.net!aioe.org!bofh.it!news.nic.it!robomod
From Florian Fainelli <f.fainelli@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port
Date Fri, 29 Sep 2017 21:30:02 +0200
Message-ID <uv990-1UI-23@gated-at.bofh.it> (permalink)
References <uv8wh-1rx-5@gated-at.bofh.it>
X-Original-To Vivien Didelot <vivien.didelot@savoirfairelinux.com>, netdev@vger.kernel.org
Dkim-Signature v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025; h=subject:to:cc:references:from:message-id:date:user-agent :mime-version:in-reply-to:content-language:content-transfer-encoding; bh=oHMRFYiRxLVDdzo6Ftpb0LD0cHv/gkU7hw2SX91lhT8=; b=GcHEOuNwc9tnn1BT/qu0Z4QAVJLylIHmMR5u9u+U+XJbVCwSXcfuVwptNB1FGMiTax k1yWjk130Htzf5PML7Cp/0gLqPDHHb9VCFpWAVFwvybZTs34OyPfgopNm5zyAGEXitN4 YjYnS/ewddh/VhjYam6BjdUVt+eyGZYAVkXfNKEhSFRv71Z400dXlyVTNMhH03Mh/dEq uLOwcUXsFuoXVJSEHbXdwzXqeuHW94FVtb6dUBhxbuzcrnRLZLRjhsggRFL0wDh+w150 xPIxSDjNGxwj2y1L1OIcVbNwt+YVg9GSzB0RJ+6sL20Gpexm0vyO0mTztSQNj4Rk63d2 Rt/g==
X-Google-Dkim-Signature v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:subject:to:cc:references:from:message-id:date :user-agent:mime-version:in-reply-to:content-language :content-transfer-encoding; bh=oHMRFYiRxLVDdzo6Ftpb0LD0cHv/gkU7hw2SX91lhT8=; b=LO7/vvYAu3kPkOSjAXvelzti7M+uL4gScI77UhBYQW7d0Mm46WKFejwhDonD+Vqnab jt2EKEaq2nDzf3xw7p7bo08WCXSPMk6Lbwoq6FdYfAjyR2nPOE2ruqN7443kK/gHONNh N8DmrIL0oZVjbj1ouweYZL03cKpOnQysqEJaHemtvm9Aj3FT8RN9vXFkhoMHJQ9x2lsw GQARvMi/POO/kRJ7KrrlJMjr6ZFQjYOBmOfBVy4dUCimLLIX9uIDja8oePsg+BfRxW3e Sao6CTG0d294N5vWF7QqKM3XRADJlqqzZw6GQEmKGwYT1ASH2p6UzW8yNyoYwf1KBJdv n7RQ==
X-Gm-Message-State AMCzsaXjy7ECug2BJrkQwHhRNai1mdVqCJH6+7lxuCi0Q/3o90aQVYXH VUlRF7smU0tg76EcSFcYMjs=
X-Google-SMTP-Source AOwi7QClZwD9CSRY74Z/GWqDTWd8gDkZ+sT/n/mJwmje5EuUqXFP1Z4PK5+6Ef+r2ESS+szhQ+3WuA==
X-Received by 10.55.16.87 with SMTP id a84mr5047928qkh.170.1506713170302; Fri, 29 Sep 2017 12:26:10 -0700 (PDT)
User-Agent Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.2.1
MIME-Version 1.0
Content-Type text/plain; charset=utf-8
Content-Language en-US
Content-Transfer-Encoding 7bit
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 50
Organization linux.* mail to news gateway
X-Original-Cc linux-kernel@vger.kernel.org, kernel@savoirfairelinux.com, "David S. Miller" <davem@davemloft.net>, Andrew Lunn <andrew@lunn.ch>
X-Original-Date Fri, 29 Sep 2017 12:26:07 -0700
X-Original-Message-ID <03cef84e-546d-d8c2-85fb-afc697ced2cb@gmail.com>
X-Original-References <20170929183635.8122-1-vivien.didelot@savoirfairelinux.com>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1742304

Show key headers only | View raw


On 09/29/2017 11:36 AM, Vivien Didelot wrote:
> With DSA, a master net_device is physically wired to a dedicated CPU
> switch port. For interaction with the DSA layer, the struct net_device
> contains a dsa_ptr, which currently points to a dsa_switch_tree object.
> 
> This is only valid for a switch fabric with a single CPU port. In order
> to support switch fabrics with multiple CPU ports, we first need to
> change the type of dsa_ptr to what it really is: a dsa_port object.
> 
> This is what this patchset does. The first 4 patches cleans up portions
> of DSA core to make the next patches more readable. These next patches
> prepare the xmit and receive hot paths and finally change dsa_ptr.

This looks nice and clean, as mentioned in patch 5, there may be room
for organizing the structure a bit more efficiently such that everything
still fits within the first cacheline .

> 
> Vivien Didelot (8):
>   net: dsa: directly fetch switch in mtk_tag_rcv
>   net: dsa: directly fetch switch in lan9303_rcv
>   net: dsa: use cpu_dp in master code
>   net: dsa: use temporary dsa_device_ops variable
>   net: dsa: add tagging ops to port
>   net: dsa: prepare master receive hot path
>   net: dsa: change dsa_ptr for a dsa_port
>   net: dsa: remove tag ops from the switch tree
> 
>  include/linux/netdevice.h |  4 ++--
>  include/net/dsa.h         | 19 ++++++++-----------
>  net/dsa/dsa.c             |  6 +++---
>  net/dsa/dsa2.c            | 15 ++++++++++-----
>  net/dsa/dsa_priv.h        |  7 +------
>  net/dsa/legacy.c          | 15 ++++++++++-----
>  net/dsa/master.c          | 47 ++++++++++++++++++++++-------------------------
>  net/dsa/slave.c           |  3 +--
>  net/dsa/tag_brcm.c        |  3 +--
>  net/dsa/tag_dsa.c         |  3 ++-
>  net/dsa/tag_edsa.c        |  3 ++-
>  net/dsa/tag_ksz.c         |  3 +--
>  net/dsa/tag_lan9303.c     |  6 ++----
>  net/dsa/tag_mtk.c         | 12 ++----------
>  net/dsa/tag_qca.c         |  3 +--
>  net/dsa/tag_trailer.c     |  3 +--
>  16 files changed, 69 insertions(+), 83 deletions(-)
> 


-- 
Florian

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
  [PATCH net-next 8/8] net: dsa: remove tag ops from the switch tree Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
  [PATCH net-next 4/8] net: dsa: use temporary dsa_device_ops variable Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
    Re: [PATCH net-next 4/8] net: dsa: use temporary dsa_device_ops  variable Florian Fainelli <f.fainelli@gmail.com> - 2017-09-29 21:20 +0200
  Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Florian Fainelli <f.fainelli@gmail.com> - 2017-09-29 21:30 +0200
    Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 21:40 +0200

csiph-web