Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1742283

[PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port

From Vivien Didelot <vivien.didelot@savoirfairelinux.com>
Newsgroups linux.kernel
Subject [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port
Date 2017-09-29 20:50 +0200
Message-ID <uv8wh-1rx-5@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


With DSA, a master net_device is physically wired to a dedicated CPU
switch port. For interaction with the DSA layer, the struct net_device
contains a dsa_ptr, which currently points to a dsa_switch_tree object.

This is only valid for a switch fabric with a single CPU port. In order
to support switch fabrics with multiple CPU ports, we first need to
change the type of dsa_ptr to what it really is: a dsa_port object.

This is what this patchset does. The first 4 patches cleans up portions
of DSA core to make the next patches more readable. These next patches
prepare the xmit and receive hot paths and finally change dsa_ptr.

Vivien Didelot (8):
  net: dsa: directly fetch switch in mtk_tag_rcv
  net: dsa: directly fetch switch in lan9303_rcv
  net: dsa: use cpu_dp in master code
  net: dsa: use temporary dsa_device_ops variable
  net: dsa: add tagging ops to port
  net: dsa: prepare master receive hot path
  net: dsa: change dsa_ptr for a dsa_port
  net: dsa: remove tag ops from the switch tree

 include/linux/netdevice.h |  4 ++--
 include/net/dsa.h         | 19 ++++++++-----------
 net/dsa/dsa.c             |  6 +++---
 net/dsa/dsa2.c            | 15 ++++++++++-----
 net/dsa/dsa_priv.h        |  7 +------
 net/dsa/legacy.c          | 15 ++++++++++-----
 net/dsa/master.c          | 47 ++++++++++++++++++++++-------------------------
 net/dsa/slave.c           |  3 +--
 net/dsa/tag_brcm.c        |  3 +--
 net/dsa/tag_dsa.c         |  3 ++-
 net/dsa/tag_edsa.c        |  3 ++-
 net/dsa/tag_ksz.c         |  3 +--
 net/dsa/tag_lan9303.c     |  6 ++----
 net/dsa/tag_mtk.c         | 12 ++----------
 net/dsa/tag_qca.c         |  3 +--
 net/dsa/tag_trailer.c     |  3 +--
 16 files changed, 69 insertions(+), 83 deletions(-)

-- 
2.14.1

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
  [PATCH net-next 8/8] net: dsa: remove tag ops from the switch tree Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
  [PATCH net-next 4/8] net: dsa: use temporary dsa_device_ops variable Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
    Re: [PATCH net-next 4/8] net: dsa: use temporary dsa_device_ops  variable Florian Fainelli <f.fainelli@gmail.com> - 2017-09-29 21:20 +0200
  Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Florian Fainelli <f.fainelli@gmail.com> - 2017-09-29 21:30 +0200
    Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 21:40 +0200

csiph-web