Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1742307
| From | Vivien Didelot <vivien.didelot@savoirfairelinux.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port |
| Date | 2017-09-29 21:40 +0200 |
| Message-ID | <uv9iF-20d-11@gated-at.bofh.it> (permalink) |
| References | <uv8wh-1rx-5@gated-at.bofh.it> <uv990-1UI-23@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Florian,
Florian Fainelli <f.fainelli@gmail.com> writes:
> On 09/29/2017 11:36 AM, Vivien Didelot wrote:
>> With DSA, a master net_device is physically wired to a dedicated CPU
>> switch port. For interaction with the DSA layer, the struct net_device
>> contains a dsa_ptr, which currently points to a dsa_switch_tree object.
>>
>> This is only valid for a switch fabric with a single CPU port. In order
>> to support switch fabrics with multiple CPU ports, we first need to
>> change the type of dsa_ptr to what it really is: a dsa_port object.
>>
>> This is what this patchset does. The first 4 patches cleans up portions
>> of DSA core to make the next patches more readable. These next patches
>> prepare the xmit and receive hot paths and finally change dsa_ptr.
>
> This looks nice and clean, as mentioned in patch 5, there may be room
> for organizing the structure a bit more efficiently such that everything
> still fits within the first cacheline .
Thanks for this very constructive comment! I'll look into this.
Respinning in a few.
Vivien
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
[PATCH net-next 8/8] net: dsa: remove tag ops from the switch tree Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
[PATCH net-next 4/8] net: dsa: use temporary dsa_device_ops variable Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 20:50 +0200
Re: [PATCH net-next 4/8] net: dsa: use temporary dsa_device_ops variable Florian Fainelli <f.fainelli@gmail.com> - 2017-09-29 21:20 +0200
Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Florian Fainelli <f.fainelli@gmail.com> - 2017-09-29 21:30 +0200
Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-09-29 21:40 +0200
csiph-web