Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1724942
| From | Thomas Gleixner <tglx@linutronix.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: Converting struct timer_list callback argument to struct timer_list * |
| Date | 2017-09-01 12:30 +0200 |
| Message-ID | <ukRn3-2DU-1@gated-at.bofh.it> (permalink) |
| References | <ukkKt-6lK-3@gated-at.bofh.it> <ukR3I-2tp-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, 1 Sep 2017, Christoph Hellwig wrote: > Good work! > > I just think that the TIMER_CONTAINER name is revolting. > > The usual name for such a helper fitting other uses like lists > and rbtrees would be timer_entry, and that also reads much better. I think the plan is to remove that thing afterward, because then the callback function is: void func(struct timer_list *timer) So I don't mind the ugly name as it should be simply removed once the tree is converted over. Thanks, tglx
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Converting struct timer_list callback argument to struct timer_list * Kees Cook <keescook@chromium.org> - 2017-08-31 01:40 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Thomas Gleixner <tglx@linutronix.de> - 2017-08-31 22:20 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Kees Cook <keescook@chromium.org> - 2017-09-01 01:40 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Christoph Hellwig <hch@infradead.org> - 2017-09-01 12:10 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Thomas Gleixner <tglx@linutronix.de> - 2017-09-01 12:30 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Christoph Hellwig <hch@infradead.org> - 2017-09-01 12:50 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Kees Cook <keescook@chromium.org> - 2017-09-01 18:30 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Christoph Hellwig <hch@infradead.org> - 2017-09-03 09:40 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Kees Cook <keescook@chromium.org> - 2017-09-03 22:20 +0200
Re: Converting struct timer_list callback argument to struct timer_list * Christoph Hellwig <hch@infradead.org> - 2017-09-04 08:10 +0200
csiph-web