Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1709774

Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32, sunxi, and zx2967

From Philipp Zabel <p.zabel@pengutronix.de>
Newsgroups linux.kernel
Subject Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32, sunxi, and zx2967
Date 2017-08-11 18:00 +0200
Message-ID <udkvU-5mU-27@gated-at.bofh.it> (permalink)
References <udhRo-3Vr-13@gated-at.bofh.it> <udhRo-3Vr-21@gated-at.bofh.it> <udkvT-5mU-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, 2017-08-11 at 23:51 +0800, Chen-Yu Tsai wrote:
> On Fri, Aug 11, 2017 at 9:06 PM, Philipp Zabel <p.zabel@pengutronix.de> wrote:
> > +static int reset_simple_probe(struct platform_device *pdev)
> > +{
> > +       struct device *dev = &pdev->dev;
> > +       const struct of_device_id *of_id =
> > +               of_match_device(of_match_ptr(reset_simple_dt_ids), dev);
> > +       const struct reset_simple_devdata *devdata = of_id->data;
> 
> Just use of_device_get_match_data().

Will do that, thanks.

> > +struct reset_simple_data {
> > +       spinlock_t                      lock;
> > +       void __iomem                    *membase;
> > +       struct reset_controller_dev     rcdev;
> > +       bool                            inverted;
> 
> You should document this option. "Inverted" by itself does not
> say a whole lot, as there is no mention about what the normal
> or non-inverted behavior is. Is the reset active low (assert
> reset when bit is cleared)? Or active high (assert reset when
> bit is set)?

You are right. Also, maybe I should rename this to
"bool active_low;" to avoid confusion where it is used.

regards
Philipp

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32, sunxi, and zx2967 Philipp Zabel <p.zabel@pengutronix.de> - 2017-08-11 15:10 +0200
  Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32,  sunxi, and zx2967 Dinh Nguyen <dinguyen@kernel.org> - 2017-08-11 17:40 +0200
    Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32,  sunxi, and zx2967 Philipp Zabel <p.zabel@pengutronix.de> - 2017-08-11 18:00 +0200
  Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32,  sunxi, and zx2967 Chen-Yu Tsai <wens@csie.org> - 2017-08-11 18:00 +0200
    Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32,  sunxi, and zx2967 Philipp Zabel <p.zabel@pengutronix.de> - 2017-08-11 18:00 +0200
  Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32,  sunxi, and zx2967 Philipp Zabel <p.zabel@pengutronix.de> - 2017-08-11 18:40 +0200
    Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32,  sunxi, and zx2967 Eugeniy Paltsev <Eugeniy.Paltsev@synopsys.com> - 2017-08-14 15:50 +0200
  Re: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32,  sunxi, and zx2967 Philipp Zabel <p.zabel@pengutronix.de> - 2017-08-14 09:30 +0200

csiph-web