Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1674323

Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings

From "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net>
Newsgroups linux.kernel
Subject Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings
Date 2017-06-25 23:20 +0200
Message-ID <tWn6P-1Mu-41@gated-at.bofh.it> (permalink)
References <tWjmy-7RM-17@gated-at.bofh.it> <tWjwd-7UO-1@gated-at.bofh.it> <tWlRo-NX-5@gated-at.bofh.it> <tWmaJ-1b8-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 25.06.2017 22:10, Joe Perches wrote:

>> Yeah, that's still an open problem. Actually, I still haven't found out,
>> how it's done w/ all the other kernel-internal conversions.
> 
> Everything else uses "%p<foo>", <object reference>

hmm, but errno's aren't pointers. Isn't %p checked for pointer values ?
>> Already was about to do so. Shall I call it strerror() ?
> 
> I presume kstrerror
> 
> So use something like
> 	"%d: (%s)", errno, kstrerror(errno)

Okay, sounds good.

--mtx

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] lib: vsprintf: add printf format conversion %M for errno strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 19:20 +0200
  Re: [PATCH] lib: vsprintf: add printf format conversion %M for  errno strings Joe Perches <joe@perches.com> - 2017-06-25 19:30 +0200
    Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 22:00 +0200
      Re: [PATCH] lib: vsprintf: add printf format conversion %M for  errno strings Joe Perches <joe@perches.com> - 2017-06-25 22:20 +0200
        Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 23:20 +0200
          Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings Randy Dunlap <rdunlap@infradead.org> - 2017-06-26 00:50 +0200
            Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-26 02:50 +0200
            Re: [PATCH] lib: vsprintf: add printf format conversion %M for  errno strings Bernd Petrovitsch <bernd@petrovitsch.priv.at> - 2017-06-27 13:10 +0200
  Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings Randy Dunlap <rdunlap@infradead.org> - 2017-06-25 19:30 +0200

csiph-web