Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1675548

Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings

From Bernd Petrovitsch <bernd@petrovitsch.priv.at>
Newsgroups linux.kernel
Subject Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings
Date 2017-06-27 13:10 +0200
Message-ID <tWWxz-84J-3@gated-at.bofh.it> (permalink)
References (1 earlier) <tWjwd-7UO-1@gated-at.bofh.it> <tWlRo-NX-5@gated-at.bofh.it> <tWmaJ-1b8-1@gated-at.bofh.it> <tWn6P-1Mu-41@gated-at.bofh.it> <tWovT-2uQ-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi all!

On Sun, 2017-06-25 at 15:47 -0700, Randy Dunlap wrote:
> On 06/25/2017 02:18 PM, Enrico Weigelt, metux IT consult wrote:
> > On 25.06.2017 22:10, Joe Perches wrote:
> > 
> > > > Yeah, that's still an open problem. Actually, I still haven't found out,
> > > > how it's done w/ all the other kernel-internal conversions.

That is hard-coded in gcc ATM TTBOMK (AFAIK BSDs ship patched gcc's for
their in-kernel extensions of format strings).

> > > Everything else uses "%p<foo>", <object reference>
> > 
> > hmm, but errno's aren't pointers. Isn't %p checked for pointer
> > values ?

Yup, and gcc will also generate a format string warning/error.

> > > > Already was about to do so. Shall I call it strerror() ?
> > > 
> > > I presume kstrerror
> > > 
> > > So use something like
> > > 	"%d: (%s)", errno, kstrerror(errno)
> > 
> > Okay, sounds good.
> 
> but why not just do that in userspace. Sure, you can keep that as your
> internal kernel patch, but there's not really much need for it to be in the
> mainline kernel.  So when your driver prints "blah: foo bar error 49",
> just run a little program that converts 49 to <whatever>.

Userspace can just guess if a given "49" is an errno or not ...

MfG,
	Bernd
-- 
Bernd Petrovitsch                  Email : bernd@petrovitsch.priv.at
                     LUGA : http://www.luga.at

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] lib: vsprintf: add printf format conversion %M for errno strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 19:20 +0200
  Re: [PATCH] lib: vsprintf: add printf format conversion %M for  errno strings Joe Perches <joe@perches.com> - 2017-06-25 19:30 +0200
    Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 22:00 +0200
      Re: [PATCH] lib: vsprintf: add printf format conversion %M for  errno strings Joe Perches <joe@perches.com> - 2017-06-25 22:20 +0200
        Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 23:20 +0200
          Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings Randy Dunlap <rdunlap@infradead.org> - 2017-06-26 00:50 +0200
            Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-26 02:50 +0200
            Re: [PATCH] lib: vsprintf: add printf format conversion %M for  errno strings Bernd Petrovitsch <bernd@petrovitsch.priv.at> - 2017-06-27 13:10 +0200
  Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno  strings Randy Dunlap <rdunlap@infradead.org> - 2017-06-25 19:30 +0200

csiph-web