Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1674303
| From | Joe Perches <joe@perches.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings |
| Date | 2017-06-25 22:20 +0200 |
| Message-ID | <tWmaJ-1b8-1@gated-at.bofh.it> (permalink) |
| References | <tWjmy-7RM-17@gated-at.bofh.it> <tWjwd-7UO-1@gated-at.bofh.it> <tWlRo-NX-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sun, 2017-06-25 at 21:53 +0200, Enrico Weigelt, metux IT consult wrote: > On 25.06.2017 19:27, Joe Perches wrote: > > > Every use of %M is going to cause gcc when using __printf to emit > > a warning like: > > > > unknown conversion type character ‘M’ in format [-Wformat=] > > Yeah, that's still an open problem. Actually, I still haven't found out, > how it's done w/ all the other kernel-internal conversions. Everything else uses "%p<foo>", <object reference> > I was under > the impression, there was some magic to tell the compiler which letters > correspond to which types - unfortunately, didn't find anything like > that. Is that really hardcoded in gcc ? > > > Beyond that, why is this useful? > > Use that instead of %d where errno values are printed/logged. > > There can't possibly be any fast-path use. > > I'm using it eg. for driver development - always having to look up the > numbers is quite ugly and time consuming. > > > Why not just create a function that does errno/string conversions? > > Already was about to do so. Shall I call it strerror() ? I presume kstrerror So use something like "%d: (%s)", errno, kstrerror(errno)
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] lib: vsprintf: add printf format conversion %M for errno strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 19:20 +0200
Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings Joe Perches <joe@perches.com> - 2017-06-25 19:30 +0200
Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 22:00 +0200
Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings Joe Perches <joe@perches.com> - 2017-06-25 22:20 +0200
Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-25 23:20 +0200
Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings Randy Dunlap <rdunlap@infradead.org> - 2017-06-26 00:50 +0200
Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings "Enrico Weigelt, metux IT consult" <enrico.weigelt@gr13.net> - 2017-06-26 02:50 +0200
Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings Bernd Petrovitsch <bernd@petrovitsch.priv.at> - 2017-06-27 13:10 +0200
Re: [PATCH] lib: vsprintf: add printf format conversion %M for errno strings Randy Dunlap <rdunlap@infradead.org> - 2017-06-25 19:30 +0200
csiph-web