Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1670425

Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations

From Gerd Hoffmann <kraxel@redhat.com>
Newsgroups linux.kernel
Subject Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations
Date 2017-06-20 10:40 +0200
Message-ID <tUmRA-6dE-9@gated-at.bofh.it> (permalink)
References (4 earlier) <tSJIC-7cs-25@gated-at.bofh.it> <tSZDH-Ds-7@gated-at.bofh.it> <tT2BA-2DV-11@gated-at.bofh.it> <tTYvT-7uN-3@gated-at.bofh.it> <tU6jO-3YD-61@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


  Hi,

> > Hmm, plane isn't really an ID, it is a type, with type being either
> > DRM_PLANE_TYPE_PRIMARY or DRM_PLANE_TYPE_CURSOR, so I don't think
> > the
> > flage above make sense.
> 
> The intention was that ..._REGION_ID and ...PLANE_ID are describing
> what the vfio_device_query_gfx_plane.id field represents, either a
> region index or a plane identifier.  The type of plane would be
> represented within the vfio_device_gfx_plane_info struct.

The planes don't really have an id, we should rename that to
plane_type, or maybe drm_plane_type (simliar to the drm_format_*
fields), to avoid that confusion.

plane_type is set by userspace to specify what kind of plane it asks
for.

> > Also I think it would be useful to have some way to figure the
> > device
> > capabilities as the userspace workflow will look quite different
> > for
> > the two cases.
> 
> In the region case, VFIO_DEVICE_GET_REGION_INFO would include a
> device
> specific region with a hopefully common identifier to identify it as
> a
> graphics framebuffer.

Ok, that should work to figure whenever the mdev supports a plane
region or not.

> In the dmabuf case,VFIO_DEVICE_QUERY_GFX_PLANE would indicate the
> plane as a "plane ID" and some sort of
> VFIO_DEVICE_GET_GFX_PLANE(VFIO_GFX_TYPE_DMABUF) ioctl would be
> necessary to get a file descriptor to that plane.
> 
> What else are you thinking we need?  Thanks,

I need to know whenever the mdev supports dmabufs or not, at device
initialization time (because dmabufs require opengl support), when
VFIO_DEVICE_QUERY_GFX_PLANE doesn't work due to the guest not having
the device initialized yet.

Maybe we should have a error field in the ioctl struct, or we need to
clearly define error codes so the kernel doesn't just throw EINVAL in
all cases.

Or just a VFIO_DEVICE_GFX_CAPS ioctl which returns NONE, REGION or
DMABUF.

cheers,
  Gerd

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v9 0/7] drm/i915/gvt: Dma-buf support for GVT-g Xiaoguang Chen <xiaoguang.chen@intel.com> - 2017-06-15 10:10 +0200
  [PATCH v9 6/7] drm/i915/gvt: Dmabuf support for GVT-g Xiaoguang Chen <xiaoguang.chen@intel.com> - 2017-06-15 10:10 +0200
  [PATCH v9 4/7] drm/i915/gvt: Frame buffer decoder support for GVT-g Xiaoguang Chen <xiaoguang.chen@intel.com> - 2017-06-15 10:10 +0200
  [PATCH v9 3/7] drm: Extend the drm format Xiaoguang Chen <xiaoguang.chen@intel.com> - 2017-06-15 10:10 +0200
    Re: [Intel-gfx] [PATCH v9 3/7] drm: Extend the drm format Ville Syrjälä <ville.syrjala@linux.intel.com> - 2017-06-15 12:30 +0200
      RE: [Intel-gfx] [PATCH v9 3/7] drm: Extend the drm format "Zhang, Tina" <tina.zhang@intel.com> - 2017-06-20 11:10 +0200
  [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Xiaoguang Chen <xiaoguang.chen@intel.com> - 2017-06-15 10:10 +0200
    Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Kirti Wankhede <kwankhede@nvidia.com> - 2017-06-15 17:00 +0200
      Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-15 18:10 +0200
        Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-15 22:40 +0200
          Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-16 12:30 +0200
            Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-16 15:00 +0200
          Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Kirti Wankhede <kwankhede@nvidia.com> - 2017-06-16 15:40 +0200
            Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-16 18:50 +0200
              Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Kirti Wankhede <kwankhede@nvidia.com> - 2017-06-16 20:30 +0200
              Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-19 08:40 +0200
                Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-19 17:00 +0200
                Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-20 10:40 +0200
                Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Kirti Wankhede <kwankhede@nvidia.com> - 2017-06-20 16:00 +0200
                Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-21 09:30 +0200
            Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-19 08:40 +0200
              Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-19 17:00 +0200
                RE: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf         operations "Zhang, Tina" <tina.zhang@intel.com> - 2017-06-20 10:50 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-20 13:00 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-20 17:10 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Kirti Wankhede <kwankhede@nvidia.com> - 2017-06-20 19:10 +0200
                RE: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations "Zhang, Tina" <tina.zhang@intel.com> - 2017-06-21 01:10 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-21 01:30 +0200
                RE: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations "Zhang, Tina" <tina.zhang@intel.com> - 2017-06-21 11:30 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-21 13:10 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-21 21:00 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-22 10:40 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-22 21:00 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-23 09:30 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Zhi Wang <zhi.a.wang@intel.com> - 2017-06-23 10:10 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-23 10:40 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-23 18:50 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-23 19:20 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-26 08:20 +0200
                RE: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations "Zhang, Tina" <tina.zhang@intel.com> - 2017-06-22 02:30 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-21 09:40 +0200
                RE: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations "Zhang, Tina" <tina.zhang@intel.com> - 2017-06-24 00:00 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-26 08:40 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Alex Williamson <alex.williamson@redhat.com> - 2017-06-26 19:30 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-27 08:20 +0200
                RE: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations "Zhang, Tina" <tina.zhang@intel.com> - 2017-06-28 14:50 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Gerd Hoffmann <kraxel@redhat.com> - 2017-06-29 08:50 +0200
                Re: [Intel-gfx] [PATCH v9 5/7] vfio: Define vfio based dma-buf  operations Daniel Vetter <daniel@ffwll.ch> - 2017-06-29 10:40 +0200
                Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Kirti Wankhede <kwankhede@nvidia.com> - 2017-06-20 15:40 +0200

csiph-web