Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1652440
| From | Linus Walleij <linus.walleij@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization |
| Date | 2017-05-29 13:40 +0200 |
| Message-ID | <tMrbI-7Eh-13@gated-at.bofh.it> (permalink) |
| References | <tKWtj-5Qx-3@gated-at.bofh.it> <tKWtk-5Qx-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, May 25, 2017 at 10:33 AM, Bartosz Golaszewski <brgl@bgdev.pl> wrote: > We're currently only checking the first character of the input to the > debugfs event files, so a string like '0sdfdsf' is valid and indicates > a falling edge event. > > Be more strict and only allow '0', '1', '0\n' & '1\n'. > > Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Since I applied patches 1-4 you only need to resend from this point when posting v2. Yours, Linus Walleij
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/10] gpio: mockup: updates for 4.13 Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
[PATCH 08/10] gpio: mockup: don't return magic numbers from probe() Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
[PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-29 09:00 +0200
Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:40 +0200
[PATCH 02/10] gpio: mockup: add prefixes to the direction enum Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 02/10] gpio: mockup: add prefixes to the direction enum Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200
[PATCH 07/10] gpio: mockup: improve readability Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
[PATCH 01/10] gpio: mockup: fix direction values Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 01/10] gpio: mockup: fix direction values Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
Re: [PATCH 01/10] gpio: mockup: fix direction values Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200
[PATCH 06/10] gpio: mockup: refuse to accept an odd number of GPIO ranges Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 06/10] gpio: mockup: refuse to accept an odd number of GPIO ranges Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 19:30 +0200
Re: [PATCH 06/10] gpio: mockup: refuse to accept an odd number of GPIO ranges Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 19:40 +0200
[PATCH 09/10] gpio: mockup: improve the error message Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
[PATCH 03/10] gpio: mockup: be quiet unless something goes wrong Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 03/10] gpio: mockup: be quiet unless something goes wrong Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200
csiph-web