Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1650311

[PATCH 02/10] gpio: mockup: add prefixes to the direction enum

From Bartosz Golaszewski <brgl@bgdev.pl>
Newsgroups linux.kernel
Subject [PATCH 02/10] gpio: mockup: add prefixes to the direction enum
Date 2017-05-25 10:40 +0200
Message-ID <tKWtk-5Qx-13@gated-at.bofh.it> (permalink)
References <tKWtj-5Qx-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


All internal symbols except for the direction enum follow the same
convention and use the gpio_mockup prefix. Add the prefix to the
DIR_IN and DIR_OUT definitions as well for consistency across the
file.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
 drivers/gpio/gpio-mockup.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpio/gpio-mockup.c b/drivers/gpio/gpio-mockup.c
index c18d011..b1ee45c 100644
--- a/drivers/gpio/gpio-mockup.c
+++ b/drivers/gpio/gpio-mockup.c
@@ -29,8 +29,8 @@
 #define	GPIO_MOCKUP_MAX_GC	10
 
 enum {
-	DIR_OUT = 0,
-	DIR_IN = 1,
+	GPIO_MOCKUP_DIR_OUT = 0,
+	GPIO_MOCKUP_DIR_IN = 1,
 };
 
 /*
@@ -93,7 +93,7 @@ static int gpio_mockup_dirout(struct gpio_chip *gc, unsigned int offset,
 	struct gpio_mockup_chip *chip = gpiochip_get_data(gc);
 
 	gpio_mockup_set(gc, offset, value);
-	chip->lines[offset].dir = DIR_OUT;
+	chip->lines[offset].dir = GPIO_MOCKUP_DIR_OUT;
 
 	return 0;
 }
@@ -102,7 +102,7 @@ static int gpio_mockup_dirin(struct gpio_chip *gc, unsigned int offset)
 {
 	struct gpio_mockup_chip *chip = gpiochip_get_data(gc);
 
-	chip->lines[offset].dir = DIR_IN;
+	chip->lines[offset].dir = GPIO_MOCKUP_DIR_IN;
 
 	return 0;
 }
-- 
2.9.3

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/10] gpio: mockup: updates for 4.13 Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
  [PATCH 08/10] gpio: mockup: don't return magic numbers from probe() Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
  [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
    Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
      Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-29 09:00 +0200
    Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
    Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:40 +0200
  [PATCH 02/10] gpio: mockup: add prefixes to the direction enum Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
    Re: [PATCH 02/10] gpio: mockup: add prefixes to the direction enum Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200
  [PATCH 07/10] gpio: mockup: improve readability Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
  [PATCH 01/10] gpio: mockup: fix direction values Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
    Re: [PATCH 01/10] gpio: mockup: fix direction values Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
    Re: [PATCH 01/10] gpio: mockup: fix direction values Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200
  [PATCH 06/10] gpio: mockup: refuse to accept an odd number of GPIO ranges Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
    Re: [PATCH 06/10] gpio: mockup: refuse to accept an odd number of  GPIO ranges Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 19:30 +0200
      Re: [PATCH 06/10] gpio: mockup: refuse to accept an odd number of  GPIO ranges Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 19:40 +0200
  [PATCH 09/10] gpio: mockup: improve the error message Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
  [PATCH 03/10] gpio: mockup: be quiet unless something goes wrong Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
    Re: [PATCH 03/10] gpio: mockup: be quiet unless something goes wrong Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200

csiph-web