Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1650320
| From | Bartosz Golaszewski <brgl@bgdev.pl> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 09/10] gpio: mockup: improve the error message |
| Date | 2017-05-25 10:40 +0200 |
| Message-ID | <tKWtk-5Qx-31@gated-at.bofh.it> (permalink) |
| References | <tKWtj-5Qx-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Indicate the error number and make the message a bit more elaborate.
Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
drivers/gpio/gpio-mockup.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/gpio/gpio-mockup.c b/drivers/gpio/gpio-mockup.c
index 3ffc3ce..96a6c6e 100644
--- a/drivers/gpio/gpio-mockup.c
+++ b/drivers/gpio/gpio-mockup.c
@@ -385,8 +385,9 @@ static int gpio_mockup_probe(struct platform_device *pdev)
}
if (ret) {
- dev_err(dev, "gpio<%d..%d> add failed\n",
- base, base < 0 ? ngpio : base + ngpio);
+ dev_err(dev,
+ "adding gpiochip failed: %d (base: %d, ngpio: %d)\n",
+ ret, base, base < 0 ? ngpio : base + ngpio);
return ret;
}
--
2.9.3
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/10] gpio: mockup: updates for 4.13 Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
[PATCH 08/10] gpio: mockup: don't return magic numbers from probe() Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
[PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-29 09:00 +0200
Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
Re: [PATCH 05/10] gpio: mockup: improve the debugfs input sanitization Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:40 +0200
[PATCH 02/10] gpio: mockup: add prefixes to the direction enum Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 02/10] gpio: mockup: add prefixes to the direction enum Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200
[PATCH 07/10] gpio: mockup: improve readability Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
[PATCH 01/10] gpio: mockup: fix direction values Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 01/10] gpio: mockup: fix direction values Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 18:50 +0200
Re: [PATCH 01/10] gpio: mockup: fix direction values Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200
[PATCH 06/10] gpio: mockup: refuse to accept an odd number of GPIO ranges Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 06/10] gpio: mockup: refuse to accept an odd number of GPIO ranges Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 19:30 +0200
Re: [PATCH 06/10] gpio: mockup: refuse to accept an odd number of GPIO ranges Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-27 19:40 +0200
[PATCH 09/10] gpio: mockup: improve the error message Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
[PATCH 03/10] gpio: mockup: be quiet unless something goes wrong Bartosz Golaszewski <brgl@bgdev.pl> - 2017-05-25 10:40 +0200
Re: [PATCH 03/10] gpio: mockup: be quiet unless something goes wrong Linus Walleij <linus.walleij@linaro.org> - 2017-05-29 13:30 +0200
csiph-web