Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1645969

Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check()

Path csiph.com!news.mixmin.net!aioe.org!news.servidellagleba.it!bofh.it!news.nic.it!robomod
From Mel Gorman <mgorman@techsingularity.net>
Newsgroups linux.kernel
Subject Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check()
Date Fri, 19 May 2017 23:40:02 +0200
Message-ID <tIXMS-86v-27@gated-at.bofh.it> (permalink)
References <tyruV-5v5-3@gated-at.bofh.it> <tyruW-5v5-17@gated-at.bofh.it> <tyy3n-1ba-1@gated-at.bofh.it> <tIPYZ-2G4-13@gated-at.bofh.it> <tISDx-4BS-43@gated-at.bofh.it> <tIWQP-7ue-37@gated-at.bofh.it> <tIWQP-7ue-35@gated-at.bofh.it> <tIXMS-86v-29@gated-at.bofh.it>
X-Original-To Zi Yan <zi.yan@cs.rutgers.edu>
MIME-Version 1.0
Content-Type text/plain; charset=iso-8859-15
Content-Disposition inline
User-Agent Mutt/1.6.2 (2016-07-01)
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 42
Organization linux.* mail to news gateway
X-Original-Cc Anshuman Khandual <khandual@linux.vnet.ibm.com>, n-horiguchi@ah.jp.nec.com, kirill.shutemov@linux.intel.com, linux-kernel@vger.kernel.org, linux-mm@kvack.org, akpm@linux-foundation.org, minchan@kernel.org, vbabka@suse.cz, mhocko@kernel.org, dnellans@nvidia.com
X-Original-Date Fri, 19 May 2017 22:39:12 +0100
X-Original-Message-ID <20170519213912.xm6zuucby3h6ne6r@techsingularity.net>
X-Original-References <20170420204752.79703-1-zi.yan@sent.com> <20170420204752.79703-3-zi.yan@sent.com> <f7a78cb0-0d91-bdbd-4a38-27f94fcefa8a@linux.vnet.ibm.com> <16799a52-8a03-7099-5f95-3016808ae65f@linux.vnet.ibm.com> <20170519160205.hkte6tlw26lfn74h@techsingularity.net> <35E3E5BA-2745-4710-A348-B6E5D892DA27@cs.rutgers.edu> <20170519202843.lco2rkkivh2a433k@techsingularity.net> <61FCE04A-0227-4D5E-92E5-81EA06979FD3@cs.rutgers.edu>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1645969

Show key headers only | View raw


On Fri, May 19, 2017 at 04:48:54PM -0400, Zi Yan wrote:
> On 19 May 2017, at 16:28, Mel Gorman wrote:
> 
> > On Fri, May 19, 2017 at 12:37:38PM -0400, Zi Yan wrote:
> >>> As you say, there is no functional change but the helper name is vague
> >>> and gives no hint to what's it's checking for. It's somewhat tolerable as
> >>> it is as it's obvious what is being checked but the same is not true with
> >>> the helper name.
> >>>
> >>
> >> Does queue_pages_invert_nodemask_check() work? I can change the helper name
> >> in the next version.
> >>
> >
> > Not particularly, maybe queue_pages_required and invert the check with a
> > comment above it explaining what it's checking for would be ok.
> >
> 
> queue_pages_required() is too broad,

I'm somewhat amused that you'd complain that "required" is too broad while
thinking "check" is somehow self-explanatory.

> I would take queue_pages_page_nid_check()
> and invert the check with a comment above saying
> 
> /*
>  * Check if the page's nid is in qp->nmask.
>  *
>  * If MPOL_MF_INVERT is set in qp->flags, check if the nid is
>  * in the invert of qp->nmask.
>  */
> 
> Does it work?
> 

I still don't like the name but I also am not interested in debating it
further for something so small. Add the comment, it's better than nothing.

-- 
Mel Gorman
SUSE Labs

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Anshuman Khandual <khandual@linux.vnet.ibm.com> - 2017-05-19 15:20 +0200
  Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Mel Gorman <mgorman@techsingularity.net> - 2017-05-19 18:10 +0200
    Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Mel Gorman <mgorman@techsingularity.net> - 2017-05-19 22:40 +0200
      Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Mel Gorman <mgorman@techsingularity.net> - 2017-05-19 23:40 +0200

csiph-web