Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1645969

Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check()

From Mel Gorman <mgorman@techsingularity.net>
Newsgroups linux.kernel
Subject Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check()
Date 2017-05-19 23:40 +0200
Message-ID <tIXMS-86v-27@gated-at.bofh.it> (permalink)
References (3 earlier) <tIPYZ-2G4-13@gated-at.bofh.it> <tISDx-4BS-43@gated-at.bofh.it> <tIWQP-7ue-37@gated-at.bofh.it> <tIWQP-7ue-35@gated-at.bofh.it> <tIXMS-86v-29@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, May 19, 2017 at 04:48:54PM -0400, Zi Yan wrote:
> On 19 May 2017, at 16:28, Mel Gorman wrote:
> 
> > On Fri, May 19, 2017 at 12:37:38PM -0400, Zi Yan wrote:
> >>> As you say, there is no functional change but the helper name is vague
> >>> and gives no hint to what's it's checking for. It's somewhat tolerable as
> >>> it is as it's obvious what is being checked but the same is not true with
> >>> the helper name.
> >>>
> >>
> >> Does queue_pages_invert_nodemask_check() work? I can change the helper name
> >> in the next version.
> >>
> >
> > Not particularly, maybe queue_pages_required and invert the check with a
> > comment above it explaining what it's checking for would be ok.
> >
> 
> queue_pages_required() is too broad,

I'm somewhat amused that you'd complain that "required" is too broad while
thinking "check" is somehow self-explanatory.

> I would take queue_pages_page_nid_check()
> and invert the check with a comment above saying
> 
> /*
>  * Check if the page's nid is in qp->nmask.
>  *
>  * If MPOL_MF_INVERT is set in qp->flags, check if the nid is
>  * in the invert of qp->nmask.
>  */
> 
> Does it work?
> 

I still don't like the name but I also am not interested in debating it
further for something so small. Add the comment, it's better than nothing.

-- 
Mel Gorman
SUSE Labs

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Anshuman Khandual <khandual@linux.vnet.ibm.com> - 2017-05-19 15:20 +0200
  Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Mel Gorman <mgorman@techsingularity.net> - 2017-05-19 18:10 +0200
    Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Mel Gorman <mgorman@techsingularity.net> - 2017-05-19 22:40 +0200
      Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Mel Gorman <mgorman@techsingularity.net> - 2017-05-19 23:40 +0200

csiph-web