Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1568033
| Path | csiph.com!1.us.feeder.erje.net!feeder.erje.net!2.eu.feeder.erje.net!news2.arglkargh.de!news.mixmin.net!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Cyrille Pitchen <cyrille.pitchen@atmel.com> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 2/9] mtd: fsl-quadspi: Rename SEQID_QUAD_READ to SEQID_READ |
| Date | Fri, 27 Jan 2017 11:50:01 +0100 |
| Message-ID | <t4cgp-2YU-3@gated-at.bofh.it> (permalink) |
| References | <sholX-538-7@gated-at.bofh.it> <sholY-538-35@gated-at.bofh.it> |
| User-Agent | Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1 |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset="windows-1252" |
| Content-Transfer-Encoding | 8bit |
| X-Brightmail-Tracker | H4sIAAAAAAAAC02Se0hTUQCHPffubndjN65z6nGFj4FRljIj62LmIxMH9iTJYc+5phvsIZuKQeF8JDQxEyVtKvioXGWCmo+mCG72UII0RSiRXEqFpZJG+IDo3q6a56+P8/3OOb/DOTgq+oZJcHVultpkUOqkXAFHIDjBCc2RlihkrY3DrXzq53wXQg2OPEOp8scVKPW7cgCjHJ1FGNU+M4FRY45aLtVb8IhHNTVMAmrVXgxiBfI/rjJE/sI2xZN32EPkHQ/y5G0LPYh8ud3/DDcV0xrSjLlXMY1jfh3NfCvMbate51nAGt8KBLiItAO4cqeBZwV83ItMhrbRKcAIMXkbwK/VRf+EiMyDnd2tGCNQshbAV83PuYzgkuFwfvolxjBBRsHSmkqEYQ4ZDAsr6mjGcW9SAS2uDDbiCYfuz3IY5pMJcLQzH2UYJWVwsLEWYzkAFnbWoOy5u2FDkR1ltoHkWTjVFMNMQ/IYtA6Vc1mOhq6qUR7LsbDb8YuzmXEsj6Es74Pdc/0Yy/th10DZRuYo7KsuR1hOhNOfmzf4JLS5LRuZVJj/xY3cBX62bTewbWtt29a6HqBPwM54+anQc+dDExTxctnBML1KkxmqV2oNYSqjvh2wb67tAcVWhRP44YjUmzjisipEO9KM165rlGbNFVO2Tm12gl04LoWEM7BEIfI0qTPUuelaHf1xNjWC850A4kKpmOAG0RnCnKnUm7UZrB8GfhJfwh1AC5IRmmzD1tr3wFviRdSIaSfMVJv02ix2/iPwwd0IPoOIOAajQS2hq3rQQwbmgC8OpF7EDNNFqDVkbR0zRzdA6Aa+K1amQZbyv5JYQLpzURchOMCtn0wUJ0h6e/uVS/nVb/pWbkZ13yt7F6JqvZCjjlxLLLm1Z/rT0+yJKpU77oaNqPshsa4GWmpLk2ZTlsaTxXsXXkcff5hSZ5/6EHe4BTXJPIIiXSP+GZdHO76ntRW2rAcc0hTA8cXTPnG+7RerWrTBK0kROZyYS6iUY9Yow0NQk1n5F5Unenh7AwAA |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 49 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Yunhui Cui <yunhui.cui@nxp.com>, <linux-mtd@lists.infradead.org>, <linux-kernel@vger.kernel.org>, <linux-arm-kernel@lists.infradead.org>, <yao.yuan@nxp.com> |
| X-Original-Date | Fri, 27 Jan 2017 11:35:31 +0100 |
| X-Original-Message-ID | <5e88a319-1533-ed1c-0dae-f84df6fe4f7c@atmel.com> |
| X-Original-References | <1471505884-33996-1-git-send-email-B56489@freescale.com> <1471505884-33996-2-git-send-email-B56489@freescale.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1568033 |
Show key headers only | View raw
Le 18/08/2016 à 09:37, Yunhui Cui a écrit :
> There are some read modes for flash, such as NORMAL, FAST,
> QUAD, DDR QUAD. These modes will use the identical lut table base
> So rename SEQID_QUAD_READ to SEQID_READ.
>
> Signed-off-by: Yunhui Cui <B56489@freescale.com>
> Signed-off-by: Yunhui Cui <yunhui.cui@nxp.com>
Applied to the spi-nor tree.
Thanks!
> ---
> drivers/mtd/spi-nor/fsl-quadspi.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/mtd/spi-nor/fsl-quadspi.c b/drivers/mtd/spi-nor/fsl-quadspi.c
> index 5ad6402..21c77e8 100644
> --- a/drivers/mtd/spi-nor/fsl-quadspi.c
> +++ b/drivers/mtd/spi-nor/fsl-quadspi.c
> @@ -193,7 +193,7 @@
> #define QUADSPI_LUT_NUM 64
>
> /* SEQID -- we can have 16 seqids at most. */
> -#define SEQID_QUAD_READ 0
> +#define SEQID_READ 0
> #define SEQID_WREN 1
> #define SEQID_WRDI 2
> #define SEQID_RDSR 3
> @@ -386,8 +386,8 @@ static void fsl_qspi_init_lut(struct fsl_qspi *q)
> for (i = 0; i < QUADSPI_LUT_NUM; i++)
> qspi_writel(q, 0, base + QUADSPI_LUT_BASE + i * 4);
>
> - /* Quad Read */
> - lut_base = SEQID_QUAD_READ * 4;
> + /* Read */
> + lut_base = SEQID_READ * 4;
>
> qspi_writel(q, LUT0(CMD, PAD1, read_op) | LUT1(ADDR, PAD1, addrlen),
> base + QUADSPI_LUT(lut_base));
> @@ -468,7 +468,7 @@ static int fsl_qspi_get_seqid(struct fsl_qspi *q, u8 cmd)
> {
> switch (cmd) {
> case SPINOR_OP_READ_1_1_4:
> - return SEQID_QUAD_READ;
> + return SEQID_READ;
> case SPINOR_OP_WREN:
> return SEQID_WREN;
> case SPINOR_OP_WRDI:
>
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH v3 2/9] mtd: fsl-quadspi: Rename SEQID_QUAD_READ to SEQID_READ Cyrille Pitchen <cyrille.pitchen@atmel.com> - 2017-01-27 11:50 +0100
csiph-web