Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1567012
| From | "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU |
| Date | 2017-01-25 23:40 +0100 |
| Message-ID | <t3Eop-7Ku-3@gated-at.bofh.it> (permalink) |
| References | <t0WhQ-3hP-13@gated-at.bofh.it> <t3CmC-6vC-45@gated-at.bofh.it> <t3DiG-76w-41@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Jan 25, 2017 at 10:26:08PM +0100, Vlastimil Babka wrote: > On 01/25/2017 09:25 PM, Johannes Weiner wrote: > >On Wed, Jan 18, 2017 at 03:07:32AM -0800, Paul E. McKenney wrote: > >>A group of Linux kernel hackers reported chasing a bug that resulted > >>from their assumption that SLAB_DESTROY_BY_RCU provided an existence > >>guarantee, that is, that no block from such a slab would be reallocated > >>during an RCU read-side critical section. Of course, that is not the > >>case. Instead, SLAB_DESTROY_BY_RCU only prevents freeing of an entire > >>slab of blocks. > >> > >>However, there is a phrase for this, namely "type safety". This commit > >>therefore renames SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU in order > >>to avoid future instances of this sort of confusion. > >> > >>Signed-off-by: Paul E. McKenney <paulmck@linux.vnet.ibm.com> > > > >This has come up in the past, and it always proved hard to agree on a > >better name for it. But I like SLAB_TYPESAFE_BY_RCU the best out of > >all proposals, and it's much more poignant than the current name. > > Heh, until I've seen this thread I had the same wrong assumption > about the flag, so it suprised me. Good thing I didn't have a chance > to use it wrongly so far :) > > "Type safety" in this context seems quite counter-intuitive for me, > as I've only heard it to describe programming languages. But that's > fine when the name sounds so exotic that one has to look up what it > does. Much safer than when the meaning seems obvious, but in fact > it's misleading. > > Acked-by: Vlastimil Babka <vbabka@suse.cz> > > >Acked-by: Johannes Weiner <hannes@cmpxchg.org> Thank you both! I have added these, as well as a Not-acked-by for Eric. ;-) Thanx, Paul > >-- > >To unsubscribe, send a message with 'unsubscribe linux-mm' in > >the body to majordomo@kvack.org. For more info on Linux MM, > >see: http://www.linux-mm.org/ . > >Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a> > > >
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-18 12:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU willy@infradead.org - 2017-01-18 12:20 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Christoph Lameter <cl@linux.com> - 2017-01-19 01:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-23 01:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Christoph Lameter <cl@linux.com> - 2017-01-25 17:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Eric Dumazet <eric.dumazet@gmail.com> - 2017-01-25 18:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-25 21:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Eric Dumazet <eric.dumazet@gmail.com> - 2017-01-25 23:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-26 00:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-19 01:20 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Johannes Weiner <hannes@cmpxchg.org> - 2017-01-25 21:30 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Vlastimil Babka <vbabka@suse.cz> - 2017-01-25 22:30 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-25 23:40 +0100
csiph-web