Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1564613
| From | "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU |
| Date | 2017-01-23 01:50 +0100 |
| Message-ID | <t2AZz-7To-17@gated-at.bofh.it> (permalink) |
| References | <t0WhQ-3hP-13@gated-at.bofh.it> <t0Wry-3oQ-65@gated-at.bofh.it> <t18sG-2zw-15@gated-at.bofh.it> <t18sG-2zw-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Jan 18, 2017 at 06:00:24PM -0600, Christoph Lameter wrote: > On Wed, 18 Jan 2017, Paul E. McKenney wrote: > > > Actually, slab is using RCU to provide type safety to those slab users > > who request it. > > Typesafety is a side effect. The main idea here is that the object can > still be accessed in RCU sections after another processor frees the > object. We guarantee that the object is not freed but it may be reused > for another object within the RCU period. > > Can we have a name that expresses all of that properly? But of course!!! "Type safety". http://wiki.c2.com/?TypeSafe Thanx, Paul
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-18 12:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU willy@infradead.org - 2017-01-18 12:20 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Christoph Lameter <cl@linux.com> - 2017-01-19 01:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-23 01:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Christoph Lameter <cl@linux.com> - 2017-01-25 17:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Eric Dumazet <eric.dumazet@gmail.com> - 2017-01-25 18:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-25 21:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Eric Dumazet <eric.dumazet@gmail.com> - 2017-01-25 23:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-26 00:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-19 01:20 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Johannes Weiner <hannes@cmpxchg.org> - 2017-01-25 21:30 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Vlastimil Babka <vbabka@suse.cz> - 2017-01-25 22:30 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-25 23:40 +0100
csiph-web