Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1566898
| From | "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU |
| Date | 2017-01-25 21:10 +0100 |
| Message-ID | <t3C3f-6mB-9@gated-at.bofh.it> (permalink) |
| References | (2 earlier) <t18sG-2zw-15@gated-at.bofh.it> <t18sG-2zw-13@gated-at.bofh.it> <t2AZz-7To-17@gated-at.bofh.it> <t3yVI-4ad-27@gated-at.bofh.it> <t3zf6-4ws-61@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Jan 25, 2017 at 09:04:47AM -0800, Eric Dumazet wrote: > On Wed, 2017-01-25 at 10:45 -0600, Christoph Lameter wrote: > > On Sun, 22 Jan 2017, Paul E. McKenney wrote: > > > > > On Wed, Jan 18, 2017 at 06:00:24PM -0600, Christoph Lameter wrote: > > > > On Wed, 18 Jan 2017, Paul E. McKenney wrote: > > > > > > > > > Actually, slab is using RCU to provide type safety to those slab users > > > > > who request it. > > > > > > > > Typesafety is a side effect. The main idea here is that the object can > > > > still be accessed in RCU sections after another processor frees the > > > > object. We guarantee that the object is not freed but it may be reused > > > > for another object within the RCU period. > > > > > > > > Can we have a name that expresses all of that properly? > > > > > > But of course!!! "Type safety". http://wiki.c2.com/?TypeSafe > > > > Well that does not convey the idea that RCU is involved here. > > > > SLAB_DESTROY_RCU_TYPESAFE > > Not clear why we need to change this very fine name ? > > SLAB_DESTROY_BY_RCU was only used by few of us, we know damn well what > it means. > > Consider we wont be able to change it in various web pages / archives / > changelogs. The reason I proposed this change is that I ran into some people last week who had burned some months learning that this very fine flag provides only type safety, not identity safety. Other proposals? Thanx, Paul
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-18 12:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU willy@infradead.org - 2017-01-18 12:20 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Christoph Lameter <cl@linux.com> - 2017-01-19 01:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-23 01:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Christoph Lameter <cl@linux.com> - 2017-01-25 17:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Eric Dumazet <eric.dumazet@gmail.com> - 2017-01-25 18:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-25 21:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Eric Dumazet <eric.dumazet@gmail.com> - 2017-01-25 23:50 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-26 00:10 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-19 01:20 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Johannes Weiner <hannes@cmpxchg.org> - 2017-01-25 21:30 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU Vlastimil Babka <vbabka@suse.cz> - 2017-01-25 22:30 +0100
Re: [PATCH RFC] mm: Rename SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-25 23:40 +0100
csiph-web