Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1561136
| From | Florian Fainelli <f.fainelli@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() |
| Date | 2017-01-18 01:00 +0100 |
| Message-ID | <t0LPs-54F-11@gated-at.bofh.it> (permalink) |
| References | <t0Lmp-4UR-7@gated-at.bofh.it> <t0Lmp-4UR-5@gated-at.bofh.it> <t0Lw7-4Y5-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 01/17/2017 03:34 PM, Andy Shevchenko wrote: > On Wed, Jan 18, 2017 at 1:21 AM, Florian Fainelli <f.fainelli@gmail.com> wrote: >> Add a helper function to lookup a device reference given a class name. >> This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and >> make it more generic. > > >> +static int device_class_name_match(struct device *dev, void *class) > > And why not const char *class? This was raised back in v2, and the same response applies: https://www.mail-archive.com/netdev@vger.kernel.org/msg147559.html Changing the signature of a callback is out of the scope of this patch series. -- Florian
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() Florian Fainelli <f.fainelli@gmail.com> - 2017-01-18 00:30 +0100
Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-01-18 00:40 +0100
Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() Florian Fainelli <f.fainelli@gmail.com> - 2017-01-18 01:00 +0100
Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-01-18 01:10 +0100
Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() Florian Fainelli <f.fainelli@gmail.com> - 2017-01-18 01:20 +0100
Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-01-18 01:10 +0100
Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() Florian Fainelli <f.fainelli@gmail.com> - 2017-01-18 01:10 +0100
Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2017-01-18 08:20 +0100
csiph-web