Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1510075

[PATCH v2 00/10] pwm: imx: Provide atomic operation for IMX PWM driver

From Lukasz Majewski <l.majewski@majess.pl>
Newsgroups linux.kernel
Subject [PATCH v2 00/10] pwm: imx: Provide atomic operation for IMX PWM driver
Date 2016-10-27 08:40 +0200
Message-ID <swMw2-6AV-11@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


This patch set brings atomic operation to i.MX's PWMv2 driver.

This work has been supported and suggested by Boris Brezillon [1] and 
Stefan Agner, by showing how simple the transition could be :-).

It has been divided into several steps:

- Provide different pwm ops for PWMv1 and PWM v2

- Separate PWMv1 commits from "generic" and non atomic PWM code.

  NOTE: Since I do not have board with PWMv1, I would like to ask somebody
        for testing

- Move some imx_config_v2 code to separate functions

- Provide PWM atomic implementation (the ->apply() driver) for PWMv2 in a
  single patch for better readability.
	
- Remove redundant PWM code (disable, enable, config callbacks)

- Update proper documentation entries

- Provide support for polarity inversion on top of atomic PWM rework

Test HW:
--------
This patch set has been tested on i.MX6q board with vanilla 4.7, 4.8 and
v4.9-rc2 kernel SHA1: 07d9a380680d1c0eb51ef87ff2eab5c994949e69


The PWM operation has been tested with pwm_bl backlight driver by changing
its brightness.

[1]: http://patchwork.ozlabs.org/patch/685402/


Lothar Wassmann (2):
  pwm: print error messages with pr_err() instead of pr_debug()
  pwm: core: make the PWM_POLARITY flag in DTB optional

Lukasz Majewski (8):
  pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2
  pwm: imx: Rewrite imx_pwm_*_v1 code to facilitate switch to atomic pwm
    operation
  pwm: imx: Move PWMv2 software reset code to a separate function
  pwm: imx: Move PWMv2 wait for fifo slot code to a separate function
  pwm: imx: Provide atomic PWM support for i.MX PWMv2
  pwm: imx: Remove redundant i.MX PWMv2 code
  pwm: imx: doc: Update imx-pwm.txt documentation entry
  pwm: imx: Add polarity inversion support to i.MX's PWMv2

 Documentation/devicetree/bindings/pwm/imx-pwm.txt |   6 +-
 drivers/pwm/core.c                                |  26 ++-
 drivers/pwm/pwm-imx.c                             | 255 ++++++++++++----------
 3 files changed, 152 insertions(+), 135 deletions(-)

-- 
2.1.4

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH v2 00/10] pwm: imx: Provide atomic operation for IMX PWM driver Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:40 +0200
  [PATCH v2 06/10] pwm: imx: Provide atomic PWM support for i.MX PWMv2 Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:40 +0200
  [PATCH v2 04/10] pwm: imx: Move PWMv2 software reset code to a separate function Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:40 +0200
    Re: [PATCH v2 04/10] pwm: imx: Move PWMv2 software reset code to a  separate function Philipp Zabel <p.zabel@pengutronix.de> - 2016-11-03 10:40 +0100
  [PATCH v2 02/10] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:40 +0200
  [PATCH v2 05/10] pwm: imx: Move PWMv2 wait for fifo slot code to a separate function Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:50 +0200
  [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to facilitate switch to atomic pwm operation Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:50 +0200
    Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Boris Brezillon <boris.brezillon@free-electrons.com> - 2016-10-27 09:50 +0200
      Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 16:40 +0200
      Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Sascha Hauer <s.hauer@pengutronix.de> - 2016-10-31 07:10 +0100
        Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Lukasz Majewski <l.majewski@majess.pl> - 2016-10-31 09:20 +0100
          Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Sascha Hauer <s.hauer@pengutronix.de> - 2016-10-31 10:30 +0100
        Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Sascha Hauer <s.hauer@pengutronix.de> - 2016-10-31 10:40 +0100
          Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Lukasz Majewski <l.majewski@majess.pl> - 2016-10-31 13:00 +0100
          Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 07:00 +0100
            Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Sascha Hauer <s.hauer@pengutronix.de> - 2016-11-01 08:20 +0100
              Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 09:30 +0100
          Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Sascha Hauer <s.hauer@pengutronix.de> - 2016-11-01 10:00 +0100
        Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Lothar Waßmann <LW@KARO-electronics.de> - 2016-11-02 08:40 +0100
          Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Sascha Hauer <s.hauer@pengutronix.de> - 2016-11-02 08:40 +0100
            Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Lothar Waßmann <LW@KARO-electronics.de> - 2016-11-02 09:00 +0100
              Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Sascha Hauer <s.hauer@pengutronix.de> - 2016-11-02 09:10 +0100
                Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Lothar Waßmann <LW@KARO-electronics.de> - 2016-11-02 10:00 +0100
                Re: [PATCH v2 03/10] pwm: imx: Rewrite imx_pwm_*_v1 code to  facilitate switch to atomic pwm operation Philipp Zabel <p.zabel@pengutronix.de> - 2016-11-02 10:40 +0100
  [PATCH v2 08/10] pwm: core: make the PWM_POLARITY flag in DTB optional Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:50 +0200
  [PATCH v2 10/10] pwm: imx: Add polarity inversion support to i.MX's PWMv2 Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:50 +0200
  [PATCH v2 07/10] pwm: imx: Remove redundant i.MX PWMv2 code Lukasz Majewski <l.majewski@majess.pl> - 2016-10-27 08:50 +0200

csiph-web