Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1494347
| From | Arnd Bergmann <arnd@arndb.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] rxrpc: split up rxrpc_send_call_packet() |
| Date | 2016-10-01 05:50 +0200 |
| Message-ID | <snjtf-2OO-1@gated-at.bofh.it> (permalink) |
| References | <snfzk-h2-3@gated-at.bofh.it> <sn8Hw-4bK-27@gated-at.bofh.it> <snfSF-or-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Saturday 01 October 2016, David Howells wrote: > commit 35510eefc29e2757c1ac46218cded2e505093fc2 > Author: David Howells <dhowells@redhat.com> > Date: Sat Oct 1 00:35:15 2016 +0100 > > rxrpc: Split rxrpc_send_call_packet() > > Split rxrpc_send_data_packet() to separate ACK generation (which is more > complicated) from ABORT generation. This simplifies the code a bit and > avoids the following warning: > > In file included from ../net/rxrpc/output.c:20:0: > net/rxrpc/output.c: In function 'rxrpc_send_call_packet': > net/rxrpc/ar-internal.h:1187:27: error: 'top' may be used uninitialized in this function [-Werror=maybe-uninitialized] > net/rxrpc/output.c:103:24: note: 'top' was declared here > net/rxrpc/output.c:225:25: error: 'hard_ack' may be used uninitialized in this function [-Werror=maybe-uninitialized] > > Reported-by: Arnd Bergmann <arnd@arndb.de> > Signed-off-by: David Howells <dhowells@redhat.com> Yes, good idea. We could probably share the part of the two functions that sets the contents of the msg and pkt variables by moving it into a third function, but I'm not sure if that actually improves readability or just reduces the number of lines. Arnd
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] rxrpc: split up rxrpc_send_call_packet() Arnd Bergmann <arnd@arndb.de> - 2016-09-30 18:20 +0200
Re: [PATCH] rxrpc: split up rxrpc_send_call_packet() David Howells <dhowells@redhat.com> - 2016-10-01 01:40 +0200
Re: [PATCH] rxrpc: split up rxrpc_send_call_packet() David Howells <dhowells@redhat.com> - 2016-10-01 02:00 +0200
Re: [PATCH] rxrpc: split up rxrpc_send_call_packet() Arnd Bergmann <arnd@arndb.de> - 2016-10-01 05:50 +0200
Re: [PATCH] rxrpc: split up rxrpc_send_call_packet() David Howells <dhowells@redhat.com> - 2016-10-01 11:20 +0200
csiph-web